How do I export or compile WYSIWIG and RETAIN LINKS

Hi all - thanks in advance for any help!

I want to:

  1. Export or compile my document
  2. Do one of the following:
    a) Retain the Scrivener links: even if they don’t go anywhere (but ideally it would be good if you could
    hover over them to get the link address in Scrivener)
    b) at LEAST make the scrivener links LOOK like links (e.g underlined, blue)
    i) I tried to create a style for this but it failed. I took a word and underlined it and made it blue, then
    made a new style called LINK, but it either didn’t work at all, or applied the style to the whole line.
    I also tried just highlighting an existing link and making a new style from that.

I’ve found that the only method that even came CLOSE to producing what I had in the editor was export to Word doc, but it had NO links at all.
All the other compiles looked NOTHING LIKE my original document.
All the font sizes were wrong.
No format that I outputted had any links, even though I ticked the box in settings saying ‘Convert document links to link back to scrivener’

What platform are you on?

You shouldn’t need styles for this, and in fact using a style will add complexity.

“Convert document links to link back to Scrivener” will link back to the Scrivener project, not internally within the output file. Make sure that’s what you actually want.

For links, make sure the general Compile option to Remove all hyperlinks is not checked. See Section 23.4 in the (Mac) Scrivener manual. For Word, make sure the Compatibility option to Ensure hyperlinks are colored and underlined is checked. See Section 24.21 in the manual. For PDF, check both the Transformations (Section 24.13) and the PDF Settings (Section 24.23) options.

For general formatting, the simplest way to get what you see in the Editor is the Default Compile Format. Many of the other formats we supply are designed to normalize the formatting.

If you haven’t already, please read at least the section on Getting Your Work Out in the Tutorial Project, available from the Help menu.

1 Like

Win 10. Thanks I’ll investigate.

Nothing changed. Everything was already set up as you suggested.


I will use numbers for easy reference.

  1. I already had UNTICKED the box ‘remove all highlights’

  2. I followed your instructions.
    a) The ‘DEFAULT’ format was already set by default to: ’ Ensure hyperlinks are colored and underlined’
    b) I duplicated and edited the DEFAULT format just in case. The copy was the same as (a)

  3. In the resulting docs, not only were no hyperlinks coloured and outlined

  4. Not only that, but text I had set to one style was changed to another style:
    a) I had set that text to ‘no style’ (i.e the default style in the general settings) but it appeared as tiny text. Why? Because it somehow adopted the style I had created to make a small 3 point space between certain lines (called ‘Small Space’)
    b) When I went to the editor, it had also CHANGED my styling for those lines of text to ‘Small Space’ as well
    c) I KNOW I had carefully set it to ‘no style’
    d) How do I know? Because it did the same thing yesterday and I had to fix it then too.

  5. I also want to note again that when I compiled to epub, the resulting document looked ABSOLUTELY NOTHING LIKE my original document. The formats were all over the place.

NOTE: I compiled to both RTF and Word 2002 (which is in your options and I prefer to use). INDEED Word 2002 has the advantage that it ALMOST works - when I use EXPORT. EXCEPT for the hyperlink markings. All the other common COMPILE methods I’ve used, and Export to PDF are a complete mess.

QUESTION: Please correct this if wrong: “You shouldn’t need styles for this, and in fact using a style will add complexity.” I assume you mean ONLY the proper marking of my hyperlinks in Word or RTF, not use of styles in general of course.


  1. As I said: the STYLING for the lines of text in the editor had changed to ‘small space’
  2. They compiled as 3 point text
  3. BUT: In the editor, they appeared the size they should (as ‘no style’ or another style I created ‘Indent 1’ or ‘Indent 2’, which indent the text by a little, and a little bit more.


Interestingly, doing so does NOT create the ‘tiny text’ error described above. Even though in the editor those lines of text have the style called ‘small space’.

COMPILING TO WORD after re-styling those bad sections back to ‘no style’:
the problem no longer occurs.
But how did it happen in the first place?

Your description is really hard to follow.
Not sure I understand what is what, but
– Is your “small space” a character attributes style or a paragraph formatting style ?
Perhaps use a narrow non-break space instead of complex formatting (?)
– Is that style listed in the Styles panel of your compile format ? (It doesn’t have to be, but that could explain some things.)
– Do you export your styles along the document at compile ?
Styles panel of the compile format :

As far as I can tell, this has nothing to do with any of this.
That is not the option @kewms told you to untick.

Thanks for your help!

  1. The ‘small space’ style is a PARAGRAPH style - its listed in the top section of the dropdown menu for styles
    I could only check your next two questions by looking at the duplicate i made of the default style (i called it “My Style”:
  2. Yes, ‘include styles info’ is ticked
  3. But there is absolutely no style listed in that box next to it

I tried to upload a pic but it wont let me.

(Thank Gough this forum actually allows pictures easily!)

He said to make sure its not ticked. It isn’t.

How do I add a picture?

If all you need is for your links to look like links, as in, you don’t care whether they are functional or not (for a print, for e.g.),
use a blue font color and underline one, select it, and create a character attributes style from it.
Apply that style to your “links”.
And then they will compile just as you see them in the editor.

(It is ill advised, but in this very specific case (for a print only) it would work.)


  1. I started an entirely fresh document
    a) It had two pages, each with a link pointing to the other

  2. Compiling to Word (2003) successfully showed the hyperlinks

  3. The document I am having trouble with was a Scrivener 1 Document imported into 3

  4. So what do I do now, since its a large document?

If there is an automatic way to handle this (import setting), I don’t know.
But you could simply one by one delete and reinsert the links in that one problematic document.
As in: delete the link, then drop the document from the binder to where the link goes again.
That will create genuine Scrivener 3 links.

(Note that internal links are compiled as such only if the target document is compiled along as well.)
. . . . . .

If the formatting problem (your “small spaces” thing) is only for this one document too,
take a snapshot of the concerned document (as a mean of backup – and as a reference for the next step),
then select all of its body text,
cut it (Ctrl-X, under windows)
then paste it back using Edit / Paste and Match Style,
and finally reformat it as it was.
– If there is some hidden code messing up the formatting, that will wipe it off.

This said, if @Kewms further replies, take her advice over mine.

[EDIT] I just realized that you call your projects “documents”… :face_with_diagonal_mouth:
Likely my advice above is garbage.

A document is an element in the binder.
A project has a bunch of documents.
There is no such thing as “pages”.

Lol thanks for your generous help!
It is indeed a valiant effort!

Just ignore everything I said.

I will try what you said but I should note that from memory I created those links NEW in Scrivener 3.
But I might have been writing on a page that was imported from Scrivener 1
I might try taking a bit of the text, copying it into notepad, pasting it back, restyling it and creating the same links.
That will be like creating a fresh version.
Maybe it will work.

No need for that.
Cut it then paste it back using Edit / Paste and Match Style.

And make sure you properly backup your project first. In case it doesn’t work and you end up with a project for which the formatting is all messed up. :wink:

1 Like

It’s great to know you can download the latest version of Scrivener** at a massive 11.2 kb per second from Amazon’s servers.

Should only take me 4 hours. Before it was saying 24 hours.

My own current net speed is supposed to be about 19.6 Mbps.

So I don’t know which end is causing the slowness.

** I decided to install fresh, JIC. My previous version was an ‘upgrade’ from a version from a while back.

Scroll to the bottom, download from there.

I’ve upgraded your trust level to allow you to post screenshots, which might be helpful.

Since this project was converted from Scrivener 1 to Scrivener 3, make sure you’ve reviewed our upgrade guide, here:

Reinstalling Scrivener won’t hurt, but shouldn’t be necessary assuming you had the latest version to begin with.

The take home: if you want your hyperlinks to be marked as such, be sure to compile the topics they point to!

It turned out that this advice from Vincent was decisive:

I didn’t realise that. So Vincent, your advice was far from ‘ignorable’!

All the hyperlinks now appear (I included their targets in the compile), except for one stubborn one, which I just can’t get to work.

Perhaps fixing that one will reveal another valuable lesson.

(I could have saved everyone a bit of trouble by posting this last night but was caught out by the ‘16 hour limitation’)

1 Like