How do I get Scrivener 3 to generate QL html?

Most of my Scrivener projects have a Quick Look file that displays a synopsis of the included files in Quick Look, but I have one that will only display the Scrivener 3 default icon.

I have tried manually saving. I have tried adding content. I have tried Save As.

I do not have Scrivener for iOS.

For some reason, none of the things that I have tried have caused this file to create a QL HTML file. Is there a trick to fixing this?


I don’t know the answer to this for certain, but Quick Look appears to display the opening content from the draft / manuscript folder (it does for all my projects, ignoring any other files or folders even if they are placed above the draft folder).

Does the miscreant project actually have text in that folder?

Slàinte mhòr.

That’s strange - the manual save should trigger the Quick Look update on its own. Try Ctrl-clicking on the .scriv project in the Finder, select “Show Package Contents” and then look to see if there is a “QuickLook” folder inside the package. If so, look to see if there is a Thumbnail.jpg file and try viewing that in QuickLook. If that’s all there, then the problem isn’t with Scrivener but Finder must be caching things and showing an older preview for some reason. If none of that is there, then something strange is definitely happening.

All the best,

Expect this might not be recommended, but having read Keith’s reply, with Scrivener closed, I duplicated a project (to create a test file) and then opened its package contents, as described above, and deleted the QuickLook folder inside the project. This, of course, meant that QL only showed a default icon when invoked. I then opened the test project, saved it, and closed it. The QL folder was recreated, and QL itself was able once again to give a meaningful preview of the project’s contents.

But possibly inadvisable.

Slàinte mhòr.

Well, I found out the answer, but I still don’t know how it occurred. There was a file in the Quick Look folder named Preview.html~. Notice the extra character after the l in the name. Moving that to the trash resolved the issue. Undoing move to trash caused the issue to recur. Redoing move to trash resolved the issue.

I looked at the content of the Scrivener 2 project. It contains both a Preview.html~ and a Preview.html with the same created date and modified date. I am guessing that this was a bug in Scrivener 2, but I don’t know.


That looks as though it might have been a syncing issue at some time - Dropbox or some other file manager creating a duplicate file with a weird name. Very strange, but I’m glad you found the fix!