How do I get the highlight back for the line I'm working in?

I’ve just upgraded to 3 and its working great. Now I want to get the highlighting of current line back. I have ticked the correct box that says highlight line in preferences, I have chosen the colour I want. I have closed preferences and have closed and opened Scrivener. I still don’t have a highlighter line when working. Help!
Getting really frustrating since I’m editing and having to scan whole pages to find the curser is far too time consuming, its driving me demented. Any help much appreciated!!!

PS. I just noticed that the option of using Inspector in dark mode - which is the option sitting beside highlighting the line - isn’t working either. This seems to be a bigger issue.

What version of Scrivener, and with which version of Mac OS?


I’m working with High Sierra and Catalina, the version is 3.2.2. :slight_smile: on both my iMac and my Macbook.

Is the problem in all projects, or just this one?

If it’s in all projects, please reset Scrivener’s Preferences file, as explained here: … references

If it’s just this one, please reset the project display settings, as explained here: … y-settings