How do I Indent the first line of a paragraph?

How do I get the first line of a paragraph indented? I am sure this is be done in Preferences/Formating, but I can’t get it done.

Preferences > Formatting then

Or you can set up a paragraph the way you want by showing the ruler — Cmd-R — setting the indent there in the same way, and then clicking the Use Formatting in Current Editor button you see there.



EDIT: That of course only affects new paragraphs. To reset existing paragraphs you need to open each document, though I guess you could do it in “Scrivenings” mode, and then choose Documents > Convert > Convert Formatting to Default Text Style

Thanks, Mark. This doesn’t change the documents I already wrote, is that correct?

For the documents youve already written, use the procedure I give in the EDIT at the end.

Thanks! Looks like you saw my 2nd question coming :slight_smile:

A follow up question (which you probably saw coming as well :smiley: ).
I would like the first paragraph in a text block not to be indented. There is an option in the compiler for this, but I don’t see a way to have this done in the editor while writing. Any suggestions?

Yes, I confess that I did wonder if you were going to ask that. :smiley:

If it’s really important to have that visually in the editor, the only way to do it is to save a paragraph preset without the indent … set up such a paragraph in the editor, have the cursor somewhere in that paragraph and then Format > Formatting > Define Preset from Selection.

But you must bear in mind that if you start a document and apply that preset immediately and start typing, when you hit return, the new paragraph will also have no indent. There are ways round this:

  • Make another preset with the indent that you can apply to the second paragraph, and that will automatically be applied to subsequent paragraphs;
  • Before you start typing, enter two returns, move the cursor back up to the first, apply the preset, type the first paragraph, and then use the down-arrow key to move it down the cursor down and your second paragraph should now have the indent;
  • You could of course combine the two as a belt-and-braces approach in case you forget the second of these;
  • Or, as a last resort, on the ruler simply just move the indent marker back to the left margin for the first paragraph after you have moved down to the second.

Personally, unless you have other reasons for using such paragraph presets—I do, giving them different colours that I can then use a macro in NWP to turn into proper styles after compiling to RTF, for instance—I wouldn’t bother in the editor and just leave removing the first line indent in the first paragraph to compile time.


I think your last suggestion is by far the best:
“I wouldn’t bother in the editor and just leave removing the first line indent in the first paragraph to compile time.”

No need to make things more complicated than necessary 8)

You would be shocked at how often good, non-complicated advice gets given here and ignored.

Mmm. I’m always struck by how resistant people are to advice on splitting their text up into small chunks; but I have always suspected that there is somewhat more resistance from new Windows users because of the hitherto less viable Scrivenings mode compared to the Mac. That should of course change with V. 3.


I can’t see how to do this within Compile on S3.

I just want every par except the first in each chapter indented.

It’s driving me mad – please help!

What I wrote above was using Scrivener 2. If you’re in Scrivener 3:

  1. Set your default text style in the Preferences to have the first line indent by adjusting the ruler;
  2. Create a paragraph style differing from the default by removing the indent, give it a suitable name and perhaps a shortcut;
  3. Use that style for any paragraphs for which you don’t want the indent;
  4. Make sure there is an equivalent paragraph style in your Compile settings.

That’s the way I do it as I want those paragraphs marked with a different style for when I open the compiled text in NWP. If that doesn’t matter to you, in Compile:

  1. Right click on your preferred base Compile format;
  2. From the dropdown menu choose Duplicate and Edit;
  3. Choose any relevant Section Layouts in turn;
  4. Place your cursor in the text area of the pane and select like this:


1 edit

Thanks much for the reply – I’ll try that!