How do I maintain an em dash when compiling?

QUESTION: How do I maintain an em dash when compiling?

I create em dashes on screen by typing – followed by [space].

If I print a single document it remains an em dash.
BUT
If I compile several documents the nice em dash reverts to two little dashes.

cheers
Jack

Hello Jack,
In the compile menu, under Transformations, have you left the ‘Convert EM dashes to double hyphens’ box still ticked?

Thanks for your reply, I did have that checked! I have now unchecked it . . .

BUT when it prints the emDash it looks more like a hyphen than a nice long emDash. Any ideas?

nb if I print a single document without compiling, then the emDash is much longer.