How do I position ToC to follow front matter?


I cannot work out to position the ToC so it sits after the title and copyright page, and before the introduction.

At present it sits immediately after the front cover. I am using Scrivener’s ‘generate HTML table of contents’ option. I have tried the manual and other resources, but I don’t understand how to make this happen.

Many thanks for your help.

From chapter 23 of the manual:

Since it mentions e-books specifically, I think that means you’ll have to create your own ToC for a print edition, as described earlier in the chapter.

Thanks Robert.

I’ve tried that and it simply doesn’t seem to work. Where is the <$toc> tag supposed to go - inside the empty document itself, or in the name of the document? It’s not clear how it works. Either way it doesn’t work (for me at any rate).

I am still struggling to make sense of this.

As the manual says, place the tag in an otherwise empty document. But there are a few other things you always need to do when creating your own ToC section anyway, and they cannot be ignored here either:

  • The name of the document can be whatever you wish it to be, and that needs to be specified in the Layout compile option pane under the HTML table of contents title field (“Contents” is the default, so if you call the document in Binder “Contents” then you can ignore setting things up in Compile, it will just work).
  • You will also need this in its own section of the e-book, internally speaking. So make sure that file has its Page Break Before option checked off in the Inspector, as well.

Instructions for all tags like this can be found in Help > Placeholder Tags List… In this case, make sure the <$toc> tag is in an otherwise blank document, and that the document name matches the name given for the contents page in Compile (e.g. “Contents”). (You may need to ensure it has a page break before and after it too, but I forget off-hand and would have to look it up - but you most likely want that anyway.)

Thanks everyone, for your help with this, and to Jeff at L&L. Now sorted. Appreciated.

And having just gone through the same exercise… I made the mistake of pressing ‘Enter’ after the <$toc> and that does not work. The tag has to really be the only thing on the page. Then everything works fine.