How do I stop formatting constantly changing on hitting the Enter key?

I’ve not had this issue with previous versions of Scrivener, only now that I’ve upgraded to Scrivener 3.

No matter what formatting I put into a document, on pressing enter it immediately reverts back to default formatting I’ve set which is driving me nuts.

For example, I’m trying to write a bulleted list in notes. I start a new line and the formatting is gone, back to my default formatting. I’ve tried making it it’s own style, but again, as soon as I press enter, bam my bullets are gone and I have to select the list style I made again.

Is there any way to get Scrivener 3 to preserve the formatting I’m currently working with and only change it when I’m actively choosing a new formatting setting to work with so it’s similar to most word processors? Having to constantly adjust style is frankly screwing with my writing flow and I’m not enjoying it.

Look at the style specification and see what the “Next Style” is.

Katherine