How do I turn off name of file and time/date?

How do I turn off name of file and time/date on printed/compiled documents? It’s frustrating. I’ve searched every where and can’t seem to find a solution. Thanks!

Do you mean that the filename and time and date are printed in the header / footer of the document that is produced?

If that’s the case, then you can get rid of them in File > Compile > All Options. Choose the Page Setup item on the left hand side and you’ll be able to amend the header and footer. You should see a couple of items (‘tags’) such as <$projectname> and <$date> in one of the boxes: delete them. [The actual tag may vary as there are a lot available: see Help > Placeholder tags list… for the full list.] You can then compile your document.

If the filename and date are appearing somewhere else, could you be give more details please?



Thank you David. That helped me enormously with the compiled documents but it still shows up when
I attempt to print the document from inside Scrivener.

Also, the font isn’t maintained when I compile to PDF (for example) but it is when I print. What gives?

Sorry, I don’t know how to get rid of the headers and footers in the File > Print dialogue. Really, most of the time it’s better to use Compile except for very quick and dirty printouts: I don’t think I’ve ever used File > Print in 4 years of using Scrivener…

I suspect that when you compile to PDF as compared to Print, one or other of them has the 'Override all fonts with face: ’ option ticked in File > Compile > Summary, or if you are in File > Compile All Options, the font is being overriden in either Formatting or in Quick Font Override. Have a look in all these places for both PDF and Print options and that’s probably where the difference in output will be found.



To print a file directly without going through Compile, but removing the stuff in the headers, if you go to “Page Setup…” at the top you have a drop down menu which says “Page attributes”. If you click on that, the menu gives you “Scrivener”. In “Scrivener” click on the “Options” button below the margin settings. In “Text Documents” at the bottom you can deselect “Print Page Numbers” and “Print File Name” and look at the other options to customise it a bit.

That’s in Mountain Lion. The way it’s laid out might be different in Lion or earlier versions of the system, but the principle will be the same.


Thanks Mark – I had a quick play around to see if I could find the answer but didn’t succeed…

Thanks David and Mark! It’s a mighty big app and when you’re wading through all of the menus, options, preferences, choices it becomes mighty daunting so I appreciate the help.

Thank you, thank you. This worked for me.