How to assign individual fonts to different styles

Hi, I have a hard time to convert a Scrivener file in a foreign language and English translation into MS Word format. Every time I tried, the default font assigned for the foreign language is broken on MS Word. Also, the styles that I have used in Scrivener are not showing up on Word. Would you please kindly teach me how to assign or to keep styles and fonts on Scrivener on MS Word? I have tried Export and Convert, but due to lack of experience and knowledge, I failed.

Thank you for your help in advance.

  1. I presume you are using Mac v. 3.1.2. If not, tell us which version.
  2. What is the foreign language, and the font you are assigning?
  3. I presume the foreign language texts are in separate binder documents, or at least separate paragraphs, rather than embedded in the English.
  4. What compile preset are you using?
  5. Have you modified the compile preset, and is “Override Text and Notes Formatting” set?
  6. Are you opening the compiled file in Word on the same machine?

Since I am doing that regularly in texts with Chinese and English, I can help you, but answers to those questions would perhaps help.

To set a font for text in a particular language, you have two options, depending on whether the language texts are separate, or some is embedded in the English. In the first case you need to set an appropriate paragraph style; in the latter you need a character style:

  1. For a paragraph style: put your cursor in a paragraph in that language in the appropriate font; go to Format > Style > New Style from Selection…; in the dialog that comes up, in the formatting section, name it, choose, “Save all formatting” ensuring that “Include Font Family” and “Include Font Size” are ticked, and any of the other options you want and click “OK”.
  2. For a character style, select some text in the font and size you want and then follow the same procedure, but where you see “Save all formatting”, click the up-down arrows and from the menu that appears choose “Save Character Attributes”.

You’ll then need to go through your text making sure your foreign language sections are given the appropriate character or paragraph styles.

If you have already done that, or if you do that and you still have this problem, then the problem is in your compile process and we need to start with the answers to my questions.

Hope that helps.