How to avoid scrivenings

When multiple documents are selected in the binder, Scrivener builds scrivenings. I’m afraid there is no way to prevent this? Or am I missing something?

Not when you select multiple documents, no, you can’t.

If when selecting a parent, this you can. In the options there is a setting.

Or you can simply toggle it here :

Ah, thanks @Vincent_Vincent I think that explains my problem.

If I select a folder in the binder and then use the option only search in binder selection, it works perfectly, even if there are many documents in this folder, because no scrivenings are created.

However, if individual documents are selected and searched for in the same way, Scrivener loses a lot of time with (in this case unnecessary) scrivenings. And apparently the scrivenings have to be rebuilt after each new search word.

Could this be the case?

You can select one of the documents from the search result after your initial search.
If you search after that for a different word, although you have a single doc selected in the search result list, the binder selection remains, and there is no longer a scrivening in the editor. (?)

Mm, no. I’ve tried a few variations…

What I actually want is this:

  1. project search “Vincent”
  2. the number of documents is reduced to 10%
  3. further search only in these 10 %
  4. so, “select all” “show in binder”
  5. selection in the search menu: search only in binder selection
  6. search for more words.

The problem is, Scrivener builds scrivenings after step 4 and repeats this after every new letter/word that is entered in the search field.

I see.

Here are clunky fixes that come to my mind :

– Type the word elsewhere (notes or synopsis panel) and cut and paste it in the search field.

– Switch the view to outliner between searches.

That’s exactly what I had in mind. But that’s … :joy:

@AmberV @kewms Or another nice person from L&L. I know that such requests are rather pointless. But because you should never give up hope completely: Would it be possible to have an option that disables scrivenings completely? Scrivenings can be really useful when you need them. But they can also be a pain. A combined search, as recommended by L&L to turn many documents into a few, does not work or is massively slowed down because Scrivener executes something that it does not need.

Scrivenings Mode is fundamental to Scrivener. It’s not my decision, but no, I wouldn’t expect an option to disable the mode completely.

You can, however, keep the Editor from reflecting the Binder selection with the Navigate → Binder Selection Affects → None option.

Thank you @kewms yes, it works much better that way.

Of course not, as predicted.

So is the binder. But it can still be hidden. Or the inspector, or the toolbar … :slightly_smiling_face:

Hidden, but not disabled.

It’s also worth noting one is not obligated to wait for Scrivenings to finish building itself. The process that handles that runs in the background, and automatically cancels if you click elsewhere or switch view modes.

Thanks, @AmberV, but when I “click elsewhere” the selection in the binder is canceled. But I need this selection to search in it. I have a collection that shows me the selected documents (instead of them being spread out in the binder).

What @kewms suggests is a good workaround. I have automated this. Before ⌘a I set it to “None”. That’s perfectly ok. :slightly_smiling_face:

Sure. Just for the sake of clarity, I was being thorough in describing how anyone, wondering about the original and very general question itself, can cancel or ignore Scrivenings and that secondly, it is possible to do so. For someone that needs the selection, but doesn’t want or need Scrivenings at the moment, turning it off is the more useful choice. Clicking elsewhere also needn’t imply changing the selection, as it also means you can do things while this is running (like setting up the next search). How effective that will be may depend on computing power though.