How to change alignment of compiled separators

Is there a way to centre justify the characters that are in the Custom Section Separator field?

i.e. the classic 3 asterisks in the centre between paragraphs or sub section in a chapter.

Since there are no controls for directly changing the formatting of separators, and all separators come out centre-aligned in file types that support the notion of formatting, it would help to know a lot more about your context. If you’re compiling a plain-text file for example, there is no way to do it short of adding the necessary number of spaces into the custom field itself.

I am trying to simply have the classic 3 asterisk separator often seen in fiction book formats.
I have formatted my binder with folders filled with one level of documents within. I would like to separate each document with such a separator and have the folders and chapters. I hope that is clearer for you.
It is a very often seen format.

At one point, I considered making a document with only the 3 asterisks centre aligned, and sticking one in between each document, but that seems like a rather silly and laborious way to achieve this goal.

You can put asterisks in Prefix and get full control of the format.

Apologies for the lack of clarity. I understand the concept of putting asterisks between portions of text where there is a major break in the content—I meant more the precise technical steps you were taking in order to put separators in between items. As I say, there is no way to actually format them (other than changing their font), and they are always centred, so in order to understand how they are coming out with different alignment, I need to know which menu commands you are clicking on, what buttons you use, the names of features, etc.

Here is an applied example that shows the level of detail I need to track down a bug or oddity, which also demonstrates how I would add a separator between two items:

  1. Go into File ▸ Compile... and double-click the highlighted compile Format that I’m using, in the left sidebar.
  2. Firstly, I set the Compile For setting at the very top to RTF. I want to be able to view the results in a word processor. Print or PDF just tells me what happened, not how.
  3. In the right-hand side of the compile overview window, I can see a list of items that will be included in the compile. You refer to them as “folders and files”, but that’s actually less relevant. What’s really important is the label under the Section Type column. From that, let’s say I have groups of items called “Chapters”, with nested items beneath that called “Scenes”. It’s the scenes I want asterisks between—but not before (as that would insert it between the chapter heading and the first scene).
  4. So I scroll through the preview column in the middle and look for the layout that is driving Scenes. When I find it, I double-click to edit it.
  5. Taking note of the name of the Section Layout that is highlighted, once the designer window opens, I click on the Separators tab in the sidebar.
  6. Ensuring that the same Layout is selected, which is being used for “Scenes”, I check the Separator between sections setting, and change it to “Custom”.
  7. In the text field to the right I paste in the classic asterism character: ⁂ because that is more fun.
  8. That’s all I need to do, so I click the Save button.
  9. Now on a Mac, I should in fact see the custom separator in the preview tile now—centre aligned, you will note! On Windows, they haven’t fixed the fact that separators don’t show up yet, but it will be there when I compile.
  10. I click Compile, choose where to save the file, and open it LibreOffice. I scroll down to a place where one should appear, and there it is, centre-aligned.

At one point, I considered making a document with only the 3 asterisks centre aligned, and sticking one in between each document, but that seems like a rather silly and laborious way to achieve this goal.

Funnily enough, that is exactly how I had to do things in version 1/2 of Scrivener, because it lacked the above described capabilities. You could either stick asterisks between all text items or none. So to only have it between some meant having a “Separator” binder item I’d create for that purpose. And yes, it was a bit silly, so thank goodness for progress.

You can put asterisks in Prefix and get full control of the format.

That is an approach, but it would then prefix every section with it, which would in some cases probably result in it being between the chapter heading and the first scene. To get around that, one would have to create a different Section Type for the first scene in every chapter—it’s more complexity for something that the Separators pane does naturally, and again for something that shouldn’t really need to be done in the first place since all separators are centre-aligned by design.

Thanks for your long reply.
I have found this dialogue and played with this setting, but I do not seem to get the centre justified result in my compiled exports.

Here it is in settings and as a result…

And here is the resulting .epub file

Screenshot 2021-11-08 093437

This is a known bug with an easy fix. Here is the original thread. The solution given there is general purpose knowledge as well. You are never stuck with the formatting Scrivener produces with epubs, you have full control with the CSS pane. So if it isn’t putting this or that correctly, you can just format it.

We do appreciate the reports if it looks to be doing something unexpected though, like this.

Hi AmberV
Thanks for leading me to this thread, but the steps in the explanation are pretty vague.
I have posted a question to it which you may be able to answer for me and others stuck like me.

In general, I have found explanations a little vague in the user manual and in this forum.
There is a protocol for explaining SW steps and/or plenty of screenshots to make it clear for those new to the SW