How to change fonts globally—can't figure out how

I have a font issue. I began a manuscript in one font. Last year, I decided to change to a different font. (using MacOS)

So I did whatever I could to change the font. But I’m not sure how. What I am sure of is the previous font continues to raise its ugly little head.

When I revise, whatever new typing I might do, in text comprised of the new font, appears in the old font. Not what I had in mind.

Little help?

Scrivener’s default font settings are housed in Scrivener > Preferences > Editing > Formatting (or Scrivener > Settings > Editing > Formatting for those using macOS 14).

Once you’ve changed the font here, it will be applied to all new documents in existing projects. It will also be used by all new projects you create.

To apply those changes to existing text, you’ll want to use Documents > Convert > Text to Default Formatting. I recommend reviewing §15.7.5 in the Scrivener manual about that command first since it can be destructive.

You can access a PDF of the manual from Scrivener’s Help menu.

I changed the font exactly where you indicated. I clicked on the little ‘Aa’ which brought up the font panel in MacOS, then selected the font I want to use.

Did I do that incorrectly? One would assume this would make all new typing appear in that chosen font.

It doesn’t.

Some of the time, maybe. But not all of the time.

I decided against using the menu command to convert existing text, bc it will not let me preserve alignment, tabs and spaces, or line spacing. All three are greyed-out.

So I selected all documents in The Binder (disclosure triangles set to display all documents), selected all text in The Editor at once, and selected the font I want from the font selection thing at the top of The Editor.

That seemed to work to take care of changing the existing text, but since only one page is visible in The Editor, we’re kind of whistling through the graveyard on that one.

But existing text is not the issue. New text is the issue, and that is where the old font keeps appearing on occasion.

I also am not overriding anything in project settings. ‘Include font family’ is checked in all styles.

The old font should be dead and gone. What I did should have rid my manuscript of it. But it’s a zombie font. It won’t go away completely. The last resort would be to delete it from the MacOS completely, but that would make it unavailable in all apps.

You need to have the cursor in the sample paragraph below to get the font to change. Did you click on that paragraph first before clicking the font button?

Yep. Tried it a number of different ways, since there is no clear indication exactly what to do.

Thanks.

But again, existing text is not the issue. New text is the issue.

Are you using a lot of styles in your project that have the old font as a part of the style?

That might explain why the global defaults aren’t being used consistently with new text.

Yes, I am.

So maybe what you’re getting at here is the styles, if older than the implementation of the new font in the global formatting (which I changed to the new font) may be hanging onto whatever font was global or in the passage the style was created from, at that point in time.

One would expect a global change of font to change it ‘globally’, but I guess that could make certain users unhappy if it also affected the font in certain styles they had created.

I can also see how it might be difficult to program Scrivener to reach in and change those styles to the updated global font, even if that is what one might expect.

I use one font. A single font, only, for these manuscripts, and I want them to reflect whatever global font choice I make in 2024, even if I change my mind in 2023 to that very font, from a previous global font chosen in 2017.

I do have ‘include font family’ checked in all styles, and maybe that would make the style hang on to whatever font it was created with, regardless of a global font change? If so, that makes sense. IOW, the style might be immune to a global font change.

Hmm. So I imagine the thing to do might be to update each style based on passages that include the newer font, maybe uncheck ‘include font family’, then recheck that.

Does it seem as if that might resolve this issue? Or are there better ways to do this?

Yes, you are correct. If a style originally included a specific font in its setup, it will retain that font until it’s redefined.

In the Scrivener manual, §17.3.3 has tips on redefining your styles. You might want to review that chapter of the manual, and that specific subsection, just to ensure that any changes you make aren’t going to cause new headaches later.

There are two options for changing an existing style:

  1. Use the Format ▸ Style ▸ Redefine Style From Selection ▸ submenu to select the style you wish to overwrite.

  2. From the style panel, right-click on the style you wish to overwrite, and select “Redefine Paragraph Style From Selection…”.

Either method should bring up the same styles panel you used to create the styles initially. You might not even need to make changes to this panel other than clicking Okay to submit the change.

That will depend on which elements you originally included in the style, and I prefer being cautious on these kinds of changes. Hence my suggestion to review the manual before redefining your styles.

Using the File > Back Up > Back Up Now command before starting to redefine your styles will give you a version you can restore from. I’m always a fan of having a good rescue point before making global changes in case something goes sideways.

2 Likes

Great advice. Thanks.

Only IF your cursor is in a new paragraph or a location where the font has been changed to the new default. Added text generally has the format of the text behind your cursor, except in the case of a new document, where the Settings default takes over. Another exception is after hitting Enter to create a new paragraph, if the old paragraph has a style; in that case the style’s Next Style setting takes over.