How to change Heading background with new dark mode?

First, I want to say that I love the new dark mode.

However, I’m kind of confused at the moment. The very first time I changed it to dark mode after the update, it turned to various shades of grey. It was perfect, I liked it just like that. But I was curious what the other built-in themes looked like so I clicked through them just for fun. When I went to set it all back to default though, it either goes straight to one of the new dark mode themes or it turns back to light. I’d really just like to have the grey theme back without having to go into Composition Mode to get to it.

I’ve managed to change most of it manually by going through the hundreds of lovely color preferences under “Appearance” but there’s one part I can’t seem to change. I’ve attached a screenshot of it and it’s fairly obvious, it’s the only part that is still blue. Can someone tell me how to change it? Or better yet, can someone tell me how to get the grey dark mode back?

Thanks so much and I love the new updates!

You can return to the standard dark mode theme by going to Scrivener > Themes and picking “Default”. That header will remain blue, though, as you cannot change that - just like you cannot change it in light mode. When you have two editors open, the editor with the focus - the one that will be affected by the binder - has a blue header bar to indicate this. This is how it has always worked, in light mode too. Probably you only had one editor open earlier - if you only have one editor open then the header is not blue as there is nothing to indicate.

I’ve had two editors open for months, I guess I just never noticed that the header was blue :confused: Thanks for pointing that out.

I may not have worded my problem with the dark mode well enough… The problem I’m running into is this: I started out in the default light mode after the update. I went Scrivener > Apearance > Dark. The screen then turned dark to only the standard dark greys.I liked it like that. Then I was easily distracted by the new themes that came with the update. I clicked through the new themes, decided I still liked the standard grey the best, and went Scrivener > Themes > Default. It turns back to light mode. I also clicked Appearance > Default and it stays in light mode (which I expected). Next, I go to Appearance > Dark and it sets it back to the last dark theme I had clicked on, Solarized Dark. I can no longer get it to go back to the grey mode at all. I’m wondering if I’m missing something here, or if the standard grey mode is no longer in existence…

Thanks for the help, i really appreciate it

I also loved the dark mode, thank you so much for that!
My question is how to make the margins in the editor have the same colors as the text area? For some reason, on my screen the text area is grayer than the margins, which have a darker shade of gray. Is that possible at all, as in the light mode margins and text area have pretty much the same color?
thank you if you could help – if that’s not possible, that’d be OK with me.

Have a look in Preferences > Appearance > Main Editor > Colours

The two settings are in Editor (ie the background to the main text) and Fixed Width Background.

To change the colours, just click on the rectangle over the Choose Texture button, and you’ll get the standard Apple Colour Swatch control.


You have to go into System Preferences: General and set your whole Mac to dark mode if you want to reset the dark theme in Scrivener, and vice versa.

To add to that, you can match the colour of anything else you see on the screen (such as the text editor background), by clicking the magnifying class icon at the very bottom of the colour palette, by the large colour swatch.

If I want a very slight variation of the editor background, I’ll first capture the colour I want to derive from, then switch to the Sliders in the colour palette (second tab), setting the mode to “HSB Sliders”. Between the Saturation and Brightness sliders you can make very small tweaks to how it looks without adjusting the hue.

Hi, Thank you so much. In fact I did follow all these steps and came across the same different colors – but then I used the dropper to select and apply the color of the text area on the margins: and now both have the same gray color and I don’t see anymore the color distinction. That’s what I wanted. Many thanks for this.

That is exactly what I was missing! Thank you, it worked!! :mrgreen:

You’re welcome! It’s worth noting we’re going to adjust that so that resetting the theme to “Default” will reset what you’re working with in Scrivener at the moment, rather than what the system is set to. So in the future you will not have to do that.