How to change the background color of text with an associated comment

Using the new release I installed this morning, when I have a comment in the Inspector, the background of the text in my manuscript associated with that content is bright pink. That’s not the color in the inspector, which is a darker pinkish color. In the editor it makes the selected text hard to read. When I go to Options / Appearance / Inspector and Notes and change the “Comments and Footnotes Area Background” color to something else, it doesn’t change in either place, even after restarting Scrivener. Any suggestion as to how to (1) get the new background color to show up in the Inspector; and (2) get it to also change in the selected text in the Editor?

If I recall correctly, that setting applies to new comments. You’d have to go into existing comments and change their color. There may be a way to do that for multiple existing comments , but cannot check as I’m not at my PC.

Thanks Jim. That spurred a bit more testing, which turned up some useful results:

  • New comments do not pick up the new background color setting that I made in Options / Appearance / Inspector and Notes / Comments and Footnotes Area Background

  • I can manually change the background for the comment in the Inspector by right clicking on it and it changes the background color in both the Inspector and Editor.

  • New comments then use the new color that I defined in the Inspector, even after closing and restarting Scrivener. But the color in the Options setting panel does not change to the one I set in the Inspector, but the one I had set earlier that never took.

It appears to me that this is a bug. The setting in Option appears to have no effect, and whatever color I set for a comment in the Inspector becomes the default for new comments.

That setting changes the background, behind all of the notes. There is no setting that would make all comments and footnotes look the same. There is a global toggle for what footnotes look like in Textual Marks, but comments are always individual.

AmberV—thank you! That helps. It still leaves open for me the question of what is the purpose of the “Comments and Footnotes Area Background” setting under Options / Appearance / Inspector and Notes ? I can’t see that anything happens as a result of changing it. No matter what I change it to, the background of both existing and new comments and footnotes is unaffected.

Perhaps you have too many comments and footnotes to see the background in the first place? I would try changing it in a document that only has one, or even none.

Got it! Thank you! It changes the background of the pane behind the comments and footnotes, not the background of the comments and footnotes themselves. Now it all makes sense. :slightly_smiling_face: