How to change the formatting of the hard return

In Dutch text a hard return does not usually mean your inserting a white space, you just start on a new line. And that’s just how I want it. How do I change this to the Dutch hard return, is that possible at all?

Shift+Enter for Windows users.

1 Like

Same keys on macOS and iOS.

1 Like

Hi, thanks for responding but that’s not my question. I would like in all texts that enter results in going to next line but not the insertion of a white line (sorry about my English, I’m Dutch).

Thanks for your response but that’s not my question.

This is the result of Enter:

This is a result of holding Shift and pressing Enter:

The second example is my interpretation of what you’re requesting.
Perhaps show an example in something you’re able to do in Word so your request may be better understood.

2 Likes

I guess in most languages a ‘hard return’ should do what you want. If white-space is added, it’s probably a setting in the formatting of paragraphs.

Paragraphs may add white-space before or after the text. To change that for the default formatting of new documents, go to Scrivener > Settings > Edit > Formatting and change the Space before and Space after values in the “Line Height” pop-up that appears when choosing the Line Height option from the Format Toolbar.

To change existing text to this default formatting, select documents in the Binder and choose Documents > Covert > Text to default formatting, leave all checkboxes as they are and choose [OK].

Ik wens je veel succes!

2 Likes

Yes that’s what I mean. I want the enters to appear as in the shift-enter. That’s how I am used to it and how all my texts are written. I’m importing text from other sources, and the enters in Dutch formatted text does not give the white extra lines.

I thought, this must surely be it, but alas! The default before and after is 0. Dank je wel!

It’s very strange you have space instead of indents for your paragraphs in the first place, as this is not a default of the software. It is not typical in English to use spaces either, unless the use is informal, like here on the forum, or blogs.

Just to make sure you are not fighting against forces you cannot see, while following the above advice to make direct formatting changes:

  • Go into Project ▸ Project Settings... and make sure that your project is not using custom formatting. Disable the checkbox if it is on. Perhaps you started with some third-party project template and the designer left this setting on by accident when they saved it.
  • Now after having done that, click into the binder and press Ctrl+N / ⌘N, then click into the editor, and type in a few lines. Is the spacing gone?

This second test is actually testing two things at once: the project’s formatting if it was set, confirmed to be gone. Or secondly, the formatting of text you imported or pasted into Scrivener, and are now working from. Each text entry in the binder can have its own formatting—well, each paragraph can have its own formatting for that matter, just like Word.

To clean up formatting, follow the tips in this knowledge base article. That will also show you how to change your defaults as well, although you’ve already seen one place you can do that in the above checklist.

2 Likes

Hi Amber, thank you for your help!

I started a new document to try this, as I didn’t dare changing my entire script, and there is no white space after a return. There is however when I select a part and change the style to block quote (wihich I use a lot as well). But because of all your answers I now knew how and where to change the blockquote appearance and could set that as the default. THANK YOU ALL! I learned a lot from al your comments!

1 Like

Excellent, yes you can redefine any style to look the way you want. You may want to know that once you get the default styles looking the way you prefer, you can make them default for new projects too:

  1. Go into the File ▸ Options..., under the Editing: Formatting tab.
  2. Click the Set Styles Defaults... button at the bottom to set your defaults for new projects from the currently active project.
1 Like

Can I suggest that, when you encounter something like this, you turn on View → Text Editing → Show invisibles. That would show you any hard return as a “pilcrow”, ¶. Any whitespace following that is the result of the line-spacing set in the editor, or as defaults in Scrivener → Preferences/Settings or Project → Project Settings….

This is where you find it:
SCR-20231020-lvnp
In the dropdown that appears, choose “Other” and adjust the settings:

SCR-20231020-lwxs-2

Once you have set your defaults, if you import any text from Word etc. which includes italics or bold you want to preserve but has different line-spacing, use Documents → Convert → Text to Default Formatting…

:slight_smile:

Mark

2 Likes