How to compile plain .txt file as UTF-8 instead of ANSI?

Is there a way to specify the encoding when you compile or export a plain text file? Right now, the character “★” appears correctly when I type it in Scrivener — but when I export or compile, it appears as something else (a capital S with a funny diacritic).

When I export as a .txt file, the output defaults to Shift JIS. Meanwhile, when I use the Compile feature, it defaults to ANSI. However, I need both options to output UTF-8.

For what it’s worth, converting the files to UTF-8 after export doesn’t seem to work, either. The :heart: character appears as a question mark when exported as ANSI, so Notepad++ is unable to detect it when I try to convert to UTF-8.

Yes, this setting can be changed in the Sharing: Import tab of the main application options (where yes, it does also impact export/compile encoding).

1 Like

Perfect, that worked. Thank you!