How to compile with different fonts?

Hi all, I’m working on a fiction novel that has two different narrators. Both voices sort of take turns to tell the whole story. I’d like to have the story printed with a different typeface for each narrator.
I know I could take the cumbersome approach to write each voice with its own font in the editor and use the AS IS option to be left untouched by the compile.
However, I wonder if there is a more simple or straightforward way, such as tagging each document with a label or keyword that identifies the narrator and then have Compile apply different formats to each of them.
Is this possible?
Many thanks in advance.

At this time we do not have a good solution to this problem. The easiest thing to do will be to just switch off the compiler formatting entirely and let the format be driven by the editor. This does reduce flexibility, however in most cases this isn’t a problem. The key thing is to be consistent in Scrivener, rather than getting things perfect. Word processors are better at applying formatting throughout a document via their stylesheet mechanisms. So as long as all of your narrator text is consistently formatted, you can use auto-format or whatever in your word processor to apply all of these texts to a style, and then update the appearance of the style.

As to the future, we do have some ideas for addressing this issue, on the long-term slate.

Thank you very much for your prompt response. I’m still in an early stage of the writing so I guess I’ll figure out later some way to do the final production. But since I’m starting I wanted to know if there was something I had to take into consideration from the beginning in order to avoid a lengthy tagging process afterwards.
Many thanks again. Best regards,

Just a bizzarre thought for you, but which I haven’t tried.

Since folders and documents in Scrivener can both hold text and both have children, and yet the text in them can be set to compile differently in terms of font, could you not use folders for one narrator and documents for the other. So you’d have Draft-folder (or Manuscript, if that’s what it is); under that Level-1-folders for Chapters where only the titles were set to compile; under that Level-2-folders, representing Narrator-A with only the text compiling in say Times New Roman Regular (or whatever you want), and documents representing Narrator-B again with only the text compiling in say Times New Roman Italic (or whatever you want).

That would work if your structure is basically simple … if you want to split your chapters up, just create new folders or documents at level two. In that way, you’d also see at a glance in the Binder which parts were narrated by which narrator. Downside, you’d have to look at the settings in the Separators pane in compile carefully.

Or, in line with Ioa’s thinking, create two presets, Narrator-A and Narrator-B with your font assignations, with “Preserve Formatting” turned on from the Format menu, and then assign those presets to the text in each chapter/section/paragraph as necessary.

Caution: I’m a Mac user, so it might be slightly different on Windows.

Mr X

Very interesting idea, xiamenese. I’m using the Novel (with parts) template and since I’m new to Scrivener I’m being extremely cautious about fiddling with the settings until I understand the collaterals of every move.
But I’l try you suggestion in the near future.
Thank you very much!
Best regards,

Hello. I hope someone is able to help with this.

In the body of my book I want to use a different font to depict an email message and another font to depict a cell phone text message.

The two fonts look fine in the editor, but when I Compile the fonts are not distinguished.

Am I going to be able to do this?

Thanks for your help in advance.


Have you gone through the interactive tutorial yet? In particular Part 3, Step 16 covers this aspect of compiling about half-way through the step. If you haven’t done the tutorial yet, I do recommend it as there are a lot of details that can enhance your usage of the software that may not immediately present themselves.

As for this particular question, it sounds like you are using template with pre-baked compile settings, or a compile preset that is designed to reformat the text of the book to a unified look (vanilla Scrivener just assumes what you type into the editor is what should be printed). This behaviour can be universally switched off in the Formatting compile option pane, with the checkbox at the top, “Override text and notes formatting”.

Thank you. I knew someone here would be able to help.