How to flatten transparencies/layers


I have run into an issue with Amazon KDP, with them saying that my book interior file contains transparencies/layers and that I need to flatten them.

Is there a way to do this in Scrivener? My manuscript has one single image on the title page. I tried to take the compiled PDF and then re-save that PDF – but this ruins the dimensions of the book.



Tried tweaking the PDF compile panel?

Thanks. I have read that but I’m not sure I’m in the right place in Scrivener.

I see these options (attached). But not a catch-all for optimizing for print-on-demand.

Click the relevant format in the Formats list in the left-hand pane of the window in your image.

Another window opens, with PDF Settings listed in the left-hand pane of the second window.



Ah, thank you. Unfortunately, I do have Optimize for print-on-demand services selected and still receive the same response from Amazon with the compiled PDF.

The one time I did try to then save that PDF as a new file, Amazon accepted the file, but it turned into 8.5x11.

Any joy if you turn off optimize for print-on-demand?

BTW, if you open a PDF in Preview and choose Export as PDF, it will create a PDF in line with your Mac’s default paper size.

However, if you choose Export… and then select PDF as the format, it SHOULD retain the original paper size.

Nope, same result. I also tried the export > select PDF rather than export as PDF and you are correct, it retained the right dimensions. But KDP still didn’t like the file.

I have reached out to Scrivener support now to see if they have any ideas. Thanks for the help.