How to get consistent formatting while writing

Hello, I am evaluating Scrivener and have come upon a very frustrating dealbreaker. I’m hoping someone here can help me find a solution, as for the most part I’m enjoying the software and feel productive. The problem is a maddening inconsistency of formatting. This is an especially bad problem on the supplied “templates” (character and story), which have multiple formats throughout the document.
As you enter text in the template, the formatting jumps about wildly. To keep the formatting the same the only solution I can find is inordinately complex: (1) choose the correct font from a lengthy dropdown, (2) removing “bold” by clicking an icon, (2) set the font color by right clicking on the font color icon, (3) resetting the line spacing, (4) increasing the indent, but only for the first line of the second following paragraph.
This is an enormous amount of work to expect of the user (customer) to have to perform for every paragraph.
Thanks in advance!

Ps. I’m not allowed to post an image here but if that changes I will attach an image illustrating the problem I’m trying to describe.

Once you’ve formatted one paragraph to work the way you want, you can use the Project → Project Settings → Formatting pane to make it the default for this project, or Scrivener → Scrivener Preferences → Editing → Formatting to make it the default Scrivener-wide.

Then, the Documents → Convert → Text to Default Formatting command will reformat existing text to the new default.

If you don’t like the existing templates, you can change them. They’re only starting points.

1 Like

Thank you I think this is what I’m looking for. The templates have at least three different formats. There’s a header format, with the purple text, then there’s the paragraph format with one font, and then there’s a deeper, mysterious format, with a completely different font, spacing, and indent. It’s a little disorienting at first.

If you add some text under the notes section of the short story templates, hit enter, and add some more texts, that will uncover at least two problems that I was trying to describe.

Thanks again.

I find that I always use blank notes and never use the character templates etc. I think they’re only ‘placeholders’, just to get the old grey cells working.

Sounds like you are in scriptwriting mode.
Are your documents’ icons yellow ?

1 Like

No I am not in script writing mode. I was just trying to report an issue, and this seems to be the only place to do so.
Again, if you open a short story template, and type some text under one of the headings, and you hit enter, and then you type some more text, everything about the appearance of the text will be different. The font will be different, the bolding will be different, the paragraphing spacing will be different, the first line tab indent will be different.
I’ve seen similar questions, and similar pushback, on Reddit as well.

I’ve tried to replicate this on Scrivener 3.3.6 on macOS 13.6.4 … I get the first step to create a new bank project based on the “Short Story Template”.

But exactly what do you mean “under one of the headings”? What headings and where are these headings?

If I go into the Scene document (first empty file under Manuscript), I don’t see any “headings” to type under and when I type in text I get Courier Prime which is my Scrivener-wide font setting.

Here is how my brand new short story project looks (screen shot). Yours any different?

1 Like

OK. I understand. (I think.)

Here is what is happening :

The heading is formatted using a style.
When you hit enter, it goes to no style.
This is how it should be.
If you want a second line of header, either use a line break (Shft-Enter) or reassign the style if you used enter and created a whole new paragraph.

What formatting you get after hitting enter is what @kewms explained earlier.


I’ve adjusted your trust level to allow you to post screenshots, because I’m really not seeing the issue.

The template sheets in the short story project have heading text, formatted in Arial Bold, and blank spaces where your own text goes. The blank spaces are formatted in Palatino Regular. If you want different formatting from that, then yes, you will need to change it throughout the template sheet, but you’ll only need to do that once.

There’s a section on Document Templates in the Tutorial project, available from the Help Menu. You might want to have a look.

1 Like