How to get the old insertion point/text cursor back if you're using Sonoma

In Sonoma, Apple changed up how their text insertion point looked, making it roundish and thick, and that carried over into Scrivener (Apple’s fault, not Scrivener’s). I hate the new insertion point, and I found a line of code on the internet that reverts the insertion point back to its previous look. It worked for me, hopefully you too.

  1. Open up your Terminal app (Applications > Utilities > Terminal)
  2. Paste this in:
    sudo defaults write /Library/Preferences/FeatureFlags/Domain/UIKit.plist redesigned_text_cursor -dict-add Enabled -bool NO
  3. Terminal will ask for your password. This is your Mac account/user password.
  4. Reboot your machine.
  5. Ta da! The pre-Sonoma insertion point is back! All is well in the world.

Good luck.


THANK YOU SO MUCH!!! Ugh! That new cursor was annoying.

Oh my god, THANK YOU

THANK YOU! I can’t believe this ACtUALLY WORKED!
I’ve worked in tech fields for 24 years, been a Mac user for 32. I’ve tried to learn code and use other people’s code many times, but this is the FIRST TIME code fixed something for me.
You have made my world a more beautiful place.

I have a MacBook Air with Sonoma 14.1.1. I’d like to try your fix, but instead of Applications, I have System Settings, and I cannot locate Utilities or Terminal within the menus. Any suggestions? This new text insertion point is driving me nuts.

If you have a Mac, you have an Applications folder. Look for it in Finder, not the menus.