How to make a micron

I’m using Japanese names in my story and want to use the micron mark above o, for instance. How can I do this?

I tried this but nothing happens. I also tried holding down the Option key and o, which gives me an o with a diaganonal line running throug it but no other choices. I’m using Mac OS 12.1.1

I am stuck on Catalina and I don’t know anything about Japanese marks at all.

But I do know that the accent menu only works for the active language. You said you use Japanese names but not that you write the whole text in Japanese.

If I assume right what you could do is to pick a Japanese font in the macOS Font Book and copy the letter you need. You could use text replacement to get that Japanese letter by writing some Latin abbreviation. If the number of Japanese names is not that high and you use them a lot it is probably handier to use text replacement for the complete names.

It works with the ABC Extended keyboard.

Then Option+B
ă ĕ ĭ ŏ ŭ

1 Like

Sorry not to be clear. I’m writing in English and just want to use macons occasionally. I use an Apple wireless Japanese keyboard in English mode. I’ve been on YouTube and tried the different methods suggested but without luck. I thought it was a problem with Scrivener but now I see it doesn’t work with MS Word, so I guess I need to contact Apple.
Thanks to those who replied. If I find out what’s causing the problem, I’ll post here, in case others have the same problem.

1 Like

Ō is Unicode U+014c/UTF8 C5 8C; ō is Unicode U+014D/UTF8 C5 8C/UTF8 C5 8D.

Rather than using an app to reassign the keyboard, if you open up the Character Viewer Edit → Emoji & Symbols, click on the button at the top left and choose “Customise List…”, then add “Unicode” to the list, you can scroll down till you find them. Double click one of them to insert it in a document, then you have two options:

  1. with the symbol highlighted in the Character Viewer, drag it to the “★ Favourites” at the top left, where it will be easily available by opening the Character Viewer and double-clicking it;
  2. create a compile replacement for a character you’re unlikely to use like ø (Opt-o), pasting ō in the “with” field.

Repeat for the other, if you need it.

The former is easier if you have a big screen, as you can work with the character viewer open all the time — if you have a small screen, it is always on top, which is a pain! — but you have to use the mouse.

The latter means that you don’t need to leave the keyboard while working, but until you compile you’ll see the character —ø in my example — in your text while working.

I think I’d follow 2 in your position as I’d be perfectly OK with an alternative character while working. You could set up a replacement in System Preferences → Keyboard → Text or use something like aText, Typinator or whatever to do it, but then you’d have to press the spacebar for the substitution to take effect, followed by deleting the unwanted space.

Hope that helps. :slight_smile:


1 Like

Actually… he could use Scrivener for that! Thinking of Project Replacements (by default not enabled outside the Screenwriting mode). :thinking:

I have to admit, I have no idea what you are talking about. There is Find → Project Replace… which doesn’t provide substitutions while you are typing, and Compile → Replacements (this is what comes up when you search the manual for “Project Replacements”), neither of which have anything to do with Screenwriting mode! It is to the latter that I referred in my post.



That’s what I mean, Project preferences:

And if you uncheck “in script mode only” (Scrivener preferences) here:

You can do this:

Pretty handy for project specific names etc.

Sorry for the confusion, it’s not called “Replacements” of course.

Hmm, I’ve gone back to the OP’s post and depending on how long his list of names is, he could use that.

But, he says he’s using a Japanese keyboard in English mode and that might be the problem. I have just tried on my UK keyboard (I’m also running Monterey), and if I hold down the “o” key I get the accent list and ō requires you to press 7. Maybe, the Japanese keyboard is different. But I’d still use Opt-o to give me ø and use a compile replacement to sort it out, as you have to hold the key down for a noticeable length of time and then type “7”, which would disturb typing flow.



Unless the feature got deliberately turned off (via Terminal or some “helpful” optimization tool) I think you’re right. But I have no idea why Apple thought this could be a good idea. The Japanese Magic Keyboard comes with Roman letters, so: “:man_shrugging:t2:”. (ō is number 8 on my QWERTZ keyboard btw., so there are definitely variations depending on the keyboard / active keyboard layout.)

I agree, but it may be good enough for the mentioned “just want to use macons occasionally”. On the other hand… writing an epic story about a Danish-Japanese Samurai could become a problem this way. Not saying the OP wants to do that. But he could.

I use macrons all the time, and they are very easy to type, provided you have the ABC Extended keyboard enabled (not sure whether it is still called that in Monterey).

To type a macron, type Opt + a and then the letter over which you wish the macron to appear. So to type “ō”, type Opt + a and then type “o”. Note that this also applies to macrons over capitals: Opt + a and then “O” → Ō.

I contacted Apple support. They weren’t able to help but are looking into the issue. It could be because I’m using an Apple English-Japanese wireless keyboard.