How to make the virtual page wider


How do I make the page view (on screen, not printout) wider?

Going left to right across the screen I have my binder, a grey space, my page, a grey space and the footnotes. Can I make my page view wider so that I don’t have so much (or any) grey space? I don’t want to make the grey space white by changing the page view. I want more horizontal space for the text: my page is too narrow. I can’t use full screen or composition mode as I’m switching between multiple apps.

Thanks! R

There are two things that could be going on here. The default editor has a maximum width constraint to avoid very long lines. You can easily adjust that in the Appearance: Main Editor: Options tab of settings. Set the Default editor width to something higher (or click the button to have it use the current editor width), or disable the feature entirely to get really long lines.

If you are in Page View mode, and the text is cut up into rectangles on the screen rather than one long scroll view, then in that same area, select the Page View section, a bit further down from the Main Editor category in the sidebar list. Note at the bottom that by default it will use your current compiler settings to adjust the visual page size. Switch that over to using the project page setup instead.

Now you can use the File ▸ Page Setup... menu command to change the paper size. There are some presets provided by the system (and your printer driver probably), but at the bottom of that dropdown you’ll find a place to add custom entries as well.

On a Mac, expand the “Scrivener” section at the bottom of this dialogue to change the margins (this can be done without expanding anything on Windows).

Overall I would say it easier to customise the non-Page View mode, but if you do really like that it cuts things into paper shaped rectangles, it’s worth the extra effort.

Hi Amber, thanks for the reply.

I went out of page view and went to settings>appearance>default editor width and increasing the width has the effect of moving the text to the left but not increasing the area of the screen the text covers.

Decreasing the margins in settings>appearance>editor margins doesn’t work either.

Do you have any other suggestions? The area of the screen the text covers, about a third, is too small for me to work with.

Thanks, R

It sounds to me then that you are talking less about the shape of the text editor, and more about undesired formatting that is cutting lines off prematurely (most likely pasted from a word processor, and spread beyond that through typing around it). Here is a thread on resetting formatting to the default look (as well as changing what that look is, to fit your taste).

It’s not a formatting problem as when pages view is on the empty space is grey (ie/ outside the document). Just to check I opened a new document and pasted matching style, this didn’t fix anything. I also went through the steps outlined in the link above, just in case, and they don’t work. Sorry :confused:

Hmm, I can’t think of what else would be moving the text container as a whole leftward rather than expanding left and right equally. There is of course the checkbox that moves the container all the way over to the left (flush with the binder), and then the width determines how far to the right it goes, but you don’t mention toggling that, and the description doesn’t really match how that works anyway.

Maybe try some “eyesore” settings to better see what is going on. In the Main Editor: Colors tab, change Fixed Width Background to something garish, like hot pink, and change Editor to bright green.

Now go back to the Options tab, and try some settings that would be within normal use—anywhere between 450 (pretty narrow) to 800 I’d say. That will at least show you where the container for the text is, and how wide it is, and whether it is wider than the window already (no pink).

The margin settings in that tab, by the way, control how close the text comes to the edges of the bright green area, as well as to the window frame itself when the window is smaller than this maximum width. For the sake of simplicity, I would set them low for now, to 20 each. Odd settings here might be confusing things.

No idea why but it worked this time! And with the added bonus of a pink background. Thank you Amber :bouquet:

1 Like

Enjoy the festive new look! :laughing: