How to mark Words as Allowed. (Spelling Okay)

Greetings,

 I'm writing a Novel and using Scrivener 2.8.1.2 on a Macbook Pro (late 2016) running Mac OS 10.12.5 (Sierra).

 I find that a lot of my Proper nouns get red underlines. Is there a way to upload a list of words that should not be flagged as spelling mistakes?

 Thanks in advance for your help.

Regards,
Rajnesh

Right-click on the word and choose “Learn spelling” in the popup menu

Thank you, Lunk.

But, is there a way to upload a file of such words?

Thanks,
Rajnesh

It is possible to have more than one dictionary but I don’t know the file format. I downloaded a dictionary from Agile Totoise (the company who makes e.g. Drafts) and use it alongside the built in dictionary.

Navigate to:
Your Home Folder > Library > Spelling > LocalDictionary

If you have words in there, it’s best practice to copy the document and tuck it away someplace safe so you can return it to that state, whenever you want.

After that, double click LocalDictionary; it will open in TextEdit (if you’ve not changed the default). Add your words to the existing list; they MUST be placed within the list in alphabetical order; close/save. Reboot your machine for the edited list to take effect. This is an OS change for your User directory so it’ll affect other apps, as well.

When I right click on the red-dotted underlined word there is no option to “Learn Spelling” or anything like it.
it just has two or three options to change the spelling.

Please help!

I do not know where to find this feature.

Thank you to anyone having this problem that has figured it out and can offer guidance.

Now you have to add it manually. Go to Edit > Spelling & Grammar > Show Spelling and add the word you want then click Learn.

I know this is an old post but ran into a similar issue and found a solution so thought I would post.

If you right click on the word and you don’t have the option to “Learn Spelling,” then try clicking so that the cursor is somewhere else in the document, then carefully, place the cursor over the word and right click. This will give you the option to “Learn Spelling.” For some reason, if the writing cursor is on the word it won’t give you that option, but I’ve found if you put the cursor somewhere else and then hover and right click on the offending word, it seems to work.

Hope this helps!

Select the word, then alt-click.

Thanks very much for this tip, FlashMarker. I was going insane looking for this feature, which was second nature in older versions. I can only think that this current issue is a bug, and I’m going to report it to the developer. In the meantime, I’m very grateful for this (only slightly inconvenient) workaround. So glad you discovered it.