how to remove blank lines between files at Compile...?

To help with the logical organization of a long essay, I often break it into a series of separate Scrivener files, some nested some not. When composing, there’s a Scrivener line separator between any two of these adjacent files. That’s fine, helpful even. But in the final output, I don’t want any separator, not even a blank line, between the text in those two adjacent files. I’ve figured out Compile’s Section Layout, etc. features well enough that in the larger book I’m outputting, I’ve got page breaks and other section-level formatting happening how I want, but I can’t seem to stop Scrivener from putting in that blank line. How do I get rid of it? Advice appreciated.

Here’s what it looks like in the Scrivener Editor:

Here’s what it looks like when it compiles:

Here’s what I want it to look like when it compiles:

I’m guessing it’s a pretty simple thing I’m missing here (probably somewhere in the Separators tab.) FYI, I’ve got the default Separator for Text files set to “Empty line” for both before and between sections, but maybe I need to set up some custom setting or use one of the “override” options… not sure, and so far my experiments here have not turned up the right combination of settings.

Thanks for any suggestions.

This? … 53#p281153

Slàinte mhòr.

Thank you, JoRo, I had misinterpreted the difference between “single return” and “empty line” and you have set me straight. I’m still sorting out a few Compiler issues, so I imagine I’ll be back on the forum soon…


Happy New Year.

Slàinte mhòr.