How to Remove Pre-formatted Double Space?

About the end of September I finally retired my (very dead) Toshiba Satellite A-70 laptop that served me well for years, but simply didn’t have any life left in it. I had used that baby through a couple of searing elections, countless columns, press conferences, articles, and through four homicide investigations and subsequent trials.

It was replaced with a brand new, shiny 13-inch MacBook Air. (Putting the MBA on top of the old Toshiba is just a crazy lesson in size difference.)

So around November I purchased Scrivener and quickly fell in love with the program. Previously, I had done virtually all of my writing in a Microsoft Word from 2003 — including my novel-in-progress.

Switching my novel into Scrivener was like a breath of fresh air. (Thank you so much.) I have greatly enjoyed using the software for my novel, and have already recommended it rather enthusiastically to my writer friends.

I have one issue at the moment, which is driving me crazy, but I presume there’s a quick fix for.

As I said, before I had done almost all of the writing for my novel on my Toshiba laptop with Microsoft Word. I had the document set (with little variation) at a traditional manuscript format of 12-point Courier New, double-spaced throughout. That way the entire thing would be ready to print in chunks for editing and proofing whenever I needed it.

However, I’ve discovered that with Scrivener’s manuscript compiling feature, there’s no point for me to work with my novel double-spaced all the time. And, to be perfectly honest, with screen real estate so valuable on a MacBook Air, I’d rather just pull out all of the spacing. I’m finding it much easier to work on the high-res screen with my document single-spaced, or just slightly above single-spaced: I can see so much more of any given chapter or section that I’m writing in that way.

Here’s the thing: In any New section that I create within my novel in Scrivener to write in, I have no trouble adjusting the spacing from double down to single-spacing, or whatever I so choose. In fact, I’ve written several chapters this way that I know will slot into different parts of the book later on. However, I can’t seem to pull out the spacing settings from the earliest portions of my novel — basically all of the work that I imported from the original Word document and then split into chapters and sections in Scrivener.

New work will respond perfectly fine to the spacing button, adjusting it up or down; but old sections will not. I adjust the spacing with the button, and it says that it has adjusted to whatever I have set it to, but there’s no visible change to the actual text. Changing Double-spacing to Single-spacing still leaves me with double-spaced paragraphs.

So, basically, I want to strip out ALL of the double-spacing throughout my entire manuscript and just set it to single-spaced. How do I go about doing that?

I’ve looked through the manual and on the forums and couldn’t find how to do this, so forgive me if this is a repeat post.

Thanks in advance for any help.

This may have nothing to do with it, but it’s worth a try…

What are the text settings look like in the Spacing… dialogue box (either Format > Text > Spacing or choose Other from the drop-down menu in the toolbar icon.

There are two settings there which affect the visible space between words: the top one (‘Line height multiple’) is the one that appears in the tool-bar menu and is the one normally associated with single-/double-spacing etc.

But there’s another one – ‘inter-line spacing’. It’s in points and it’s normally set to 0.0. Is it possible that Word has been using that, rather that the line height multiple?

May be wrong, but worth a look?



If you are used to working in Word you are probably expecting formatting in Scrivener to work like styles in Word – but it doesn’t. In Scrivener you select the text first, then change the formatting. Formatting only affects selected text, whereas in Word you can change a style and anything that is formatted with that style will immediately change to reflect that alteration. Perhaps this is part of the problem you are having, but I’m guessing.



I think David has hit the nail on the head here. As he says, if you select “Other…” from the bottom of the spacing pull-down (or if you go to Format > Text > Spacing…), you will see this panel:

When you select a line spacing multiple from the pull-down menu, it only affects the pull-down menu - it won’t presume to change any other paragraph formatting you’ve set up. For that, you need to adjust it directly in this panel. A line-height multiple of 2 will look identical to an inter-line spacing setting of 12 (or whatever the font size is). So, if you set that to 0, you should be good.

There’s a quicker way to reformat all of these documents, though:

  1. In the Preferences, go to “Formatting” and set up the default formatting you want to use in new documents:

(This way, you don’t have to keep changing the spacing to whatever you prefer every time you create a new document, as if you set your preferred spacing and suchlike here, new documents will use it by default.)

  1. Select any existing documents in the old format and go to Documents > Convert > Formatting to Default Text Style… This will change the formatting of the selected documents to match that set in the preferences. If the spacing is set as you want it in the preferences, you won’t have to fiddle with the spacing controls for those old documents by doing this, as the conversion process will take care of all of that for you.

Hope that helps.

All the best,

Regarding #2: New users often get tripped up here. The trick is to select all your documents in the binder before invoking the conversion to default. If you try to select the text of your documents, that menu option will not be available.

What if you want to set up for new documents the indent for the bullets in a list and the distance from a bullet to its text. Where can that be done?


I think there is a way of doing it, but it’s not particularly elegant (not Scrivener’s fault: it’s the downright silly way Apple has chosen to implement list styles.)

a) Create the first line of your bullet list.

b) Change the pre-bullet and post-bullet distances using the Ruler (cmd-R to toggle it on/off). You do this by dragging the different types of tab in the ruler to the desired settings – experiment to get the right effect.

c) Once you’ve got it the way you want it, select the entire line and choose Format > Formatting > New Preset From Selection. Give the new Preset a name (e.g. ‘MyBullet’), and choose the options you want. I’d maintain Save All Formatting, but it’s up to you whether to include the font and font size.

Now, when you want to use bullets, choose the bullet (or number style) you want in the normal way (i.e. from Format > Lists or the drop-down menu). Then choose your preset MyBullet from Format > Formatting > Apply Preset > MyBullet. (BTW to make things easier, you can give your new preset a shortcut key in System Preferences in the normal way.)

This setting will now persist for the rest of your list.

In fact it will persist for the rest of that document (until you either change the ruler or add another preset), including for number lists and bare text. That’s because all you’re actually doing here is redefining the ruler to take account of your preferred bullet settings.

You could do this by making your changes and then using Copy Ruler (ctl-cmd-C) and Paste Ruler ctl-cmd-V). But then those settings wouldn’t be persistent across sessions. Using presets allow you to make changes that carry over to all documents.

Actually, I hope someone knows a quicker way than this – it works, but it’s clunky…

Keith, David and Robert,

Thank you very much, good sirs.

A combination of those suggestions worked great for me, and I was able to pull out all of the pre formatted double-spacing that was being such a pesky problem and eating up all of the screen real estate in my work area. Looking at the spacing table, apparently all of the text from my novel that I imported from my old Word file (MicroSoft Word 2003) showed up with “Inter-line spacing” set at 30 points. Thirty! No wonder the double-spacing looked ridiculously huge in those sections on my MacBook Air. Working in a 12-point Courier New type, that 30 points was a good deal MORE than double-spaced. ugh!

I changed the preferred formatting in the preferences menu so it was all set to single-spacing for the project, as per Keith’s suggestion. Then I applied that new default text setting to all of the problem parts. It worked great, with the minor exception that it pulled out and deleted a bunch of my first-line indents on paragraphs. Quite randomly, too. A chapter would have everything indented fine, and then seven or eight paragraphs in a row that the first line indent was removed from. Very odd, but not a terrible thing to have to fix. I went through and took care of all the misplaced (or missing) indents. So all is good now.

Now then, I have a cup of coffee in me, a kettle on the stove for tea, and my adjusted manuscript in front of me. Time to get some work done.

Thanks again to all for the fast responses and the great tips to get everything set and running for me again.

It is much appreciated.


Hi Jack,

Glad that helped!

Hmm, that shouldn’t happen. Have you got a first line indent set in the preferences? I’m wondering if some paragraphs had a first line indent set and others had a tab character inserted. If there was no first line indent set in the preferences, then when you converted the text, any paragraph without a tab character starting it would have become left-aligned, whereas anything with a tab character would have maintained its look of having a first line indent. To check this, go to Format > Options > Show Invisibles and look to see if there is a little blue arrow before some of the paragraphs - the arrow indicates that there’s a tab character. In general, it’s better to use the first line indent in the ruler rather than preceding paragraphs with a tab, as that will give you more flexibility when you come to compile.

Right, time for my coffee now, too!

All the best,