How to remove the Header/Footer on select pages?


How do I remove the Header on selected pages during the Compile process?

Example: For whatever reason, I don’t want the Header to appear on, say, page 2, 17, and 89.


How do I remove page numbering on selected pages?

Example: For whatever reason, I don’t want the page numbers to appear on page 32 and 41.

I don’t think you can designated specific pages to remove the header/footer, but you can designate specific situations when they won’t be printed. This is covered in Section 24.20.5 of the manual.

E.g. ‘No header on new pages following page breaks’, …on single pages, on blank pages etc.

Depending on what your requirements actually are, you may find that a combination of these is enough ‚ but it does depend on what you’re trying to do, I think.

Thanks so much for the prompt reply.

As I understand, basically your answer is, “No, yYM, Scrivener does not do what you need.” Enter QuarkXPress or InDesign. :frowning:

Compile for: PDF

Scrivener does have the option of removing these layout-type elements on blank pages. These blank pages generally precede Section Title Pages. Then, as is often with paperbacks and how-to manuals, the headers, footers, and page numbers are absent from the Section Title Pages. Note the highlighted portions in the image below.

An Exception: When Section Title Pages have accompanying text, the page number will probably appear. It’s not, however, always the case that the header/footer will always appear on this page.

In the situation you’re showing above (assuming no other problem), then the answer is ‘yes’, isn’t it?

It’s difficult to give you more specific advice without more details - eg what exactly are you expecting to see ouput from this binder arrangement? Perhaps screenshots of successive pages (normal page, ‘wrong page’, normal page), details of the section layouts you’ve used, separators, page breaks etc.

Thanks for the help.

Looking at the current options, it seems this would be an easy addition. Hopefully the software engineers at LL will include this in a future update.


Sorry, what would be an ‘easy addition’? It’s not clear what you mean.

please see my edit above.

First, I’m under no illusion Scrivener is limited in its layout capabilities. That being said, however, various norms have been established in the industry—and for years. And it seems, from what I understand about Scrivener’s header/footer options, we’ve establish it’s not possible to implement my design needs.


1—A paperback’s Section Title Page generally has no header, footer, or page number. I cannot get Scrivener to do this simple thing.

2—Another single Section Page (preceded by a blank section divider page) which includes the Section Title, TOC, yet no header, footer, or page number.

3—The layout designer, in this case (and for consistency reasons), included the page number. Yet, as you can see, the header is absent.

From the date inside the paperback, I’m guessing this was created in QuarkXPress. The others are from InDesign. In any case, this was/is standard layout nonetheless.

BONUS ISSUES - If You Wish to Assist

— First Pages, when they do have page numbers, generally have a Roman-style. i, ii, iii, etc. Not sure if this is possible.

— Aside from their automatic appearance in the TOC created by Scrivener, I’ve yet to understand how to create ‘leader dots’ (leaders) when and/or where I need them. Example: They often appear in list items. 2.jpg has an example of this.

Thanks again,


You should be able to do most of what you’re looking for in Scrivener: as I said, it’s a matter of getting the right combination of Section Layouts and header/footer settings.

The first one’s easy. (By which I mean, there’s a single setting to cover it — but you have to create the right conditions first.)

Here’s a screenshot of your first requirement – a ‘standalone’ section page with no header or footer followed by a full text page with both header and footer. Obviously, yours will look different in many ways, but the basic procedure is the same.

I compiled this by having a section type called Section and a ‘text page’ section type called Scene (the names don’t matter as long as you differentiate between types).

In compilation, I then associated ‘Section’ with a Section Layout which printed out only the section title and number, with a page break before. I’ve given the scenes a layout which has a page break before, but not title or number. Just pick one layout for each type to look roughly how you want it and remember the names.

Then I edited the format (ie right-click on paperback and choose Duplicate and Edit or just Edit) and clicked on Separators then on the section layout I’d used for Section. (In the screenshot I’ve renamed them to make it obvious, but this isn’t necessary). As you can see, for the Scene layout, I set the Separator Before to be Page Break, and the Separator Between to be Empty line. For the Section layout, both were set to Page Break. The effect of these settings is to isolate every Section page to a single page, which means we can trigger the ‘no header or footer’ setting in a moment.

Finally, in the Page Layout section, make sure you’ve ticked the Options > No Header or Footer on Single pages setting. Now click on the Header and Footer tab and make sure the Main Body line has the correct Header and Footer bar for those pages which will have them.

That’s basically it — the other examples should be possible using different combinations of these settings. Obviously, there is a certain level of complexity where you’d be better off doing it in Quark or another dedicated problem, but for the relatively simple layouts you’ve shown here, Scrivener should be able to handle it.

If some of the steps I’ve taken don’t make much sense at the moment, then it might be worth reading the compilation section in the Tutorial again. If it still doesn’t work, then the best thing to do is to create a dummy project with enough content to cover all your requirements and then post it on here and we can try to help.


For your other questions:

To make the first pages use Roman numerals, first make sure that in the same Page Layout dialogue, under the Options tab, you have ‘Different Header and Footer on first pages’ ticked. This time, when you go into the Header and Footer Text tab, you’ll see that First has appeared alongside Main. Click on First, then in the footer use the tag <$p-r> (or <$p-R> if you want them to be capitals), instead of the usual <$p> tag which gives your Arabic numerals.

Not sure about the TOC question, sorry.



Thanks ever so much for your assistance—especially your time invested. Later today I’ll attempt your solution(s).



Well…so…I’ve worked on this issue (off and on) for over a week now. At this point I know Scrivener quite well. In any case, I’m simply not able to get Scrivener to look as I wish; that would include trying to match the layout design used in Ligature and Latte’s own User Manual for macOS—which is almost industry standard.


You instructed, “…make sure you’ve ticked the Options > No Header or Footer on Single pages setting.”

If I’m not mistaken, what this effectively does is eliminate all headers and footers on all single pages in the entire document. I.e., regardless of any combinations applied in the Section Layouts settings, and for any or all Section Types, all single pages have their headers and/or footers removed.

So, for example, a single page in a text section which should have a header with a page number no longer does. Yikes!

There needs to be a way (via placeholders at least) to override, and thereby control, an individual page’s layout. So using an example above: if I want the header line to be removed from page 9-1 (for whatever reason—maybe I’m superstitious)…I can make it so. Having to resort to QuarkXPress or InDesign for such basic layout (generally controlled via Master Pages) is quite frustrating.



AFAIK, the manual is written and compiled in Scrivener, so if you can see what you want there, then you can achieve it too. My guess is that you need to find the right combination of ‘different header and footer on pages following page breaks’ and blank/single pages, but I’ve deleted the test file I used to answer your question and I don’t have time to recreate it — sorry.

Try this: tick…

Different header and footer on first pages — takes care of the front matter
Main body/footer starts — After front matter
Different header/footer on pages following page break
No header/footer on blank pages

This gives you three choices in the Header and Footer text panel:
First pages (for the front matter headers)
New Pages (whenever there’s a page break — so will be used on any suitable section layout which includes a page break in its definition (Parts etc according to your setup)
Main Body (everything else.

For testing purposes, I suggest you give each of these a meaningful header (eg ‘First pages header’, ‘New Pages’ header etc) so you know what you’re getting in the output.

This seems to work fine — the headers are where I’d expect them to be. But I don’t know your document structure, so you’ll have to experiment — it’s possible a setting somewhere else is throwing you off.

If you can’t get it to work, I think your best bet is to zip the project up (or a cut down version with enough to recreate the problem) and send to support with a more detailed explanation of your requirements.

Good luck.


Thanks for the continued instructions. I do sincerely appreciate it. I think the best advice, however, is for me to recreate a miniature version of the User Manual for macOS and zip it off. I’m guessing, however, I could be wrong, it’s not possible to do exactly what I want in the order I want it. Why…


Please, if you have time, reference the User Manual for macOS.

1—The header, footer, and page number layout on iv does not match page v.
2—Page 21 is missing its header, footer, and page number.
3—Pages 55, 86, 110, 138 suffer the same error.
4—Page 136’s page number is centered; no header or footer exists.
5—Oops, page 241 has a header line—but without the title; the number is now not centered. The following page is missing its header, footer, and page number.
6—Pages 734 and 735 are incorrect with regards to previous sections.
7—Page 794 does not match Pages 818, and 819; 825 and 826.
8—Pages 840, 841, and 842 are different still.


I don’t know who constructed this manual or the layout, but it’s not consistent. I’ve been doing layout since the 90s. I clearly see what the designer attempted. I can do this in minutes with Quark or InDesign. If the experts at LL could not get Scrivener to layout the their own manual consistently throughout, is it any wonder I’m having issues?

Note: I had already made sever test projects as you’ve suggested. They all fail one way or the other.



I don’t know which copy of the manual you’re looking at, but your description bears no resemblance to the copy I have — most are either clearly a design choice, or they don’t look like you say they do:

1—The header, footer, and page number layout on iv does not match page v. page iv is a new section so it has a different header/footer — design choice clearly
2—Page 21 is missing its header, footer, and page number. page 21 is a Part header made up of a full page graphic, so it has a different header/footer — design choice clearly
3—Pages 55, 86, 110, 138 suffer the same error. Ditto
4—Page 136’s page number is centered; no header or footer exists. p136 is the start of Part II, so of course it’s a different header/foorter. Clearly a design choice
5—Oops, page 241 has a header line—but without the title; the number is now not centered. The following page is missing its header, footer, and page number. No it isn’t — both pages are correct and consistent.

The rest of your points in that list are similarly inaccurate. It seems to me that you must be looking at a earlier non-production version of the manual. Download the latest one and you’ll see that the manual does what you seem to be asking for it to do.

The manual is written by AmberV, who posts on here — if you’ve got any specific questions about how the manual (the up to date one) is produced to get the various headers, it’s probably best to start a new post with his name in the title. In the past the actual project used has been available on the web site — it will probably be back up soon enough.

(BTW, the screenshots you provide don’t really help without seeing the compilation settings — that’s why I suggested you create a dummy project with the compilation settings you’ve tried and then send it to support for their advice)