How to remove the red lines when using foreign language

I am using the trial and getting to know the program. I write both in English and Korean, but when I write in Korean, every single word gets a red spelling error line… and it is a lot of work to click one by one to get rid of them. I wonder if I can turn this feature off on a project?

I really don’t like seeing the red lines…

In the Windows version, you only have the option to have one Dictionary enabled at a time, so that’s definitely one place the macOS version shines (this is due to the use of underlying Apple technology, not an oversight on the part of our Windows developers).

One option would be to change the dictionary to Korean. I would have the dictionary set to whichever language you write in primarily. If you write in Korean and English equally, you can choose whichever you prefer.

  • Launch Scrivener
  • Go to File → Options → Corrections → Spelling
  • Click the “Download” button next to the Dictionary language box
  • Select your language of choice and click “Download.”
  • Click “Close” when the download has completed.
  • Click “Select” and click on the language dictionary you would like to use.
  • Click “Okay.”

You can also turn off the option to “Check spelling as you type” in the Spelling tab where you change the dictionary. That will get rid of the red lines while you write.

It fixed just right. Thank you so much!