How to stop two dashes from being turned into an em dash?

Hi. This is as much a general Mac question as a Scrivener question.

Somewhere, on my Mac, I have a setting which changes two dashes into an em dash. So when I type two dashes, then hit space, the two dashes are replaced by an em dash. This happens in most applications, including Scrivener. However, it doesn’t happen when I type in a web browser – so it’s apparently not a universal setting.

But I can’t figure out where this setting is and how to change it. I looked in System Preferences> Keyboard> Text, but there’s no shortcut there for turning two dashes into an em dash.

Does anyone know where the setting might be?

I don’t want dashes to be turned into an em dash when I’m writing in Scrivener using Script Mode.



I should add, in the Keyboard>Text preferences I unchecked “Use smart quote and dashes” but that didn’t make a difference.

Have you unchecked Scrivener > Preferences > Corrections > Replace a double hyphen with em-dashes?

nontroppo, that worked! Thank you. I haven’t used Scrivener for a number of months so I forgot about those settings.

I just looked in Scrivener 3 on my MacBook and cannot find that option. Has it been relocated?

It has been renamed, I think it is now called Preferences :arrow_forward:︎ Corrections :arrow_forward:︎ Use smart dashes and ellipses in new projects, and to toggle it in existing projects Edit :arrow_forward:︎ Substitutions :arrow_forward:︎ Smart dashes and Ellipses.

That is checked, but when I type two dashes and a SPACE the two dashes are not replaced with an EM dash.
I’m using Scrivener version 3.0.2.

Possibly you need to check System Preferences :arrow_forward:︎ Keyboard :arrow_forward:︎ Text :arrow_forward:︎ Use smart quotes and dashes too?

That is checked too.

The strange thing is I just discovered that in other apps, such as the Notes app, if I type two dashes and a SPACE, the dashes are replaced with an em dash. Further, if I try to do it in other templates in Scrivener 3, such as the Blank template, as soon as I type the second dash both dashes are automatically converted to an em dash. The problem seems to occur only in the US Stage Play template.

There is a setting for screen/stage writing, could that be it?

How do I get to that setting?

Under Preferences > Corrections, beneath the “Use smart dashes and ellipses in new projects” checkbox, there is another checkbox: “Disable smart dashes and ellipses in script mode”. If that is ticked, smart dashes will not be used in scripts such as US Stage Play.

All the best,

I see it. Thank you very much. Am I correct that it is preferable to leave that checkbox checked?

I believe so - most scripts use two hyphens for dashes still, from what I have read.

Thank you – I love you! So grateful to you. Been screwing around with this for half an hour. This worked.

I had that problem too, the toggle was the problem. Nicely done!