How to turn off auto-capitalisation after question mark in dialogue

Hello, apologies if this has been covered elsewhere, but I couldn’t find it in the forums:

I have turned off ‘Auto Capitalisation’ in the preferences (preferences–>corrections–>Auto Capitalization–>fix capitalization of sentences), but Scrivener is still auto-correcting words after dialogue, for example:

“Is this a question mark?” he asked. The ‘h’ of ‘he’ is changed to a capital ‘H’: “Is this a question mark?” He asked.

also:

“An exclamation mark!” she exclaimed, becomes: “An exclamation mark!” She exclaimed.

I can’t see how to turn off this function. Have I missed a setting in the preferences?

Thanks in advance,
Ian

I have “Fix capitalisation of sentences” still checked, but I get:

“An exclamation mark!” she exclaimed.

Could it be a system setting that’s overriding Scrivener, for example System Preferences / Keyboard / Text / correct spelling as you type? (Which I DON’T have checked). (ETA: I’ve checked that but it doesn’t alter what I get.

Ah thank you! You were in the right place - there was a ‘capitalise words automatically’ checkbox in that system preferences dialogue which turned out to be the culprit.

Many thanks.

Cool. :slight_smile:

I’m French and in French, the issue of auto-capitalisation after a question mark or an exclamation mark in dialogue is quite important as what follows those marks are always verbs, not the subject of the phrase. So in French, you will write that :
— Laisse moi ! dit Mike.
that is literally :
— Leave me alone ! said Mike.
and not as in correct English :
— Leave me alone ! Mike said.

Same with ‘?’ in dialogue.

So as in English :

  • no capital in French after a ‘?’ and ‘!’ in dialogue,
  • apart from dialogues, in other parts of the text, we write a capital after a question mark or an exclamation one.

In Scrivener, if I ain’t mistaken, there are two ways not to have a capital after ! and ? in dialogue :
(1) Have auto-capitalisation on and Cmd+Z after a ‘?’ or ‘!’ in dialogue so the capital disappears.
That way, you have capitals after dots (. and …) and marks (? and !).
(2) Have auto-capitalisation off and add them with Shift+letter every time you need them (for . … ? ! in the main text)

Word uses another system : auto-capitalisation after dots (. and …) but no capitalisation after ? and !
With that you need to add capital after ‘?’ and ‘!’ every time you need it.
An interesting solution.

But, IMHO, I feel that the fluidity of my writing would benefit from Scrivener being able to make that process automatic. It would be nice is if Scrivener could ‘guess’ (from say the presence/absence of : Enter + ‘—’) whether or not to put a capital after a question mark or an exclamation one or if scripts could be written by users.

I know it might appear as a triviality to some.

Am I missing something ? Is it possible ?

1 Like

Hi,

What do you mean by auto-capitalisation on + cmd+Z so the capital disappears?
It doesn’t work with me…

  1. “Auto-capitalisation on” = Scrivener, Preferences, Auto-Correction, tick the box “Fix capitalization of sentences”
  2. “Cmd + Z” = Undo
    This will automatically create a capital letter, then turn it into a lower case letter (undo).

Thanks for your quick answer. I did just that, but for me, cmd+Z just remove the last bit of text typed, it doesn’t turn the former capital letter into a lower case one…

It will only do it if you do the Cmd-Z immediately after the uppercase has been created, usually as soon as you type a space or punctuation at the end of the word. It won’t go back and do it if you have typed anything else first.

Your mac should make a sound as it changes the case, so you should Cmd-Z immediately after you hear that sound.

HTH

Mark

Indeed. xiamenese is right.

Type a word at the start of a line, for example :
‘she’
then press space, ‘she’ becomes 'She ’
press cmd+Z
'She ’ turns into 'she ’

(Sorry I forgot to mention pressing space/punctuation)