how to turn off spellcheck?

I just upgraded to 2.0 yesterday and have a couple questions…

  1. How do I turn off the spellcheck completely? I don’t want to see the red squiggly lines under every character name, and I also don’t want to have to fiddle with the dictionary every time I introduce another character. I don’t want a spellcheck at all.
    EDIT: never mind, found it. :stuck_out_tongue: (Edit menu, Spelling, turn off “check while typing”.)

  2. How do I set the text color, especially in fullscreen? In the previous version, I had cyan text on black background. I’ve found how to get the black background again, but not how to change the black text. Corollary question - why couldn’t 2.0 have just remembered all my settings from 1.54?

You can also have it turned off for new projects by default by deselecting the option in the “Auto-Correction” preferences pane.

You can do this via the “Full Screen” pane of the Preferences.

Because they use different preferences files so that users can run 1.x alongside 2.0 for a while if they want - if they have projects they need to keep in 1.x format for a while, or if they are just trying out 2.0. If they had the same preferences, 2.0 would keep trying to open 1.x projects and vice versa.

Hope that helps,
Keith

You can do this via the “Full Screen” pane of the Preferences.
[/quote]
I’m clearly missing the obvious … which one? I see ways to change the color on all sorts of different backgrounds, but nothing for the actual text?

Is there a way to copy the file over from one to the other? Mostly I just liked my color choices from before, and it took a lot of fiddling to get them there the first time, and now all the buttons to do it a second time have moved…

Scrivener>Preferences:Full Screen, at the very top check the box to override natural text color and select the color you want to use instead.fullscreen text color.png

Since the preferences changed a lot from 1.54 to 2.0, there’s not a way to just copy the preference file. (Edit Lies, all lies; Keith explains how to do it below. Whoops! The rest may still be of interest anyway, so I leave it.) If your main concern is colors and you have 1.54 still around on your computer, you could open that version and put your color choices there onto the custom palette of the Color Picker, thus making them easily available when you set colors in 2.0. The manual, toward the beginning of Appendix B, has a list of the different customizable color options accessible through the Preferences:Appearance pane, which may help out a bit (around p.330 in the US letter format).

Actually, there is a way, because the internal names haven’t changed for many options - but you will still need to go through the options because a lot of the preferences have changed, so even if you transfer the settings across, not everything may be maintained. Anyway, here’s how:

  1. Go to ~/Library/Preferences in the Finder (where the tilde indicates your home folder).

  2. Locate the file entitled “com.literatureandlatte.scrivener2.plist” and move it to the Trash.

  3. Locate the file entitled “com.literatureandlatte.scrivener.plist” and rename it, adding the “2” to the end of “scrivener”, to become “com.litertureandlatte.scrivener2.plist”.

You must ensure that Scrivener is closed while you do this. Also note that when you relaunch Scrivener, it will no longer know your registration details, so you will need to re-enter your user name and 2.0 serial number.

EDIT: Alternative Solution

Actually, there is another way you can do it, too, without having to re-enter your serial number. Just download Scrivener 1.x from the blue sidebar here: literatureandlatte.com/scriv … w=features Then launch 1.x, go to the Preferences, click on “Manage…” in the bottom left-hand corner and choose to save the preferences. After that you can close 1.x and delete it again if you want. Then, in 2.x, open the Preferences panel, click on “Manage…” and choose to load the preferences file you just saved from 1.x. This should allow Scrivener 2.0 to load your 1.x preferences.

All the best,
Keith

Ahaha. I stand corrected. :slight_smile: