How to widen screenplay action format to match FD?

If I compile from scrivener for final draft, then open in final draft, I find that there is one extra character per line allowed for Action. It’s a small thing, but when trimming screenplay pages, every character counts. I know that if I include the “extra” characters in scrivener they will display properly in FD, but it would be great to see the effects “live” in scrivener.

I tried adjusting via Format->Scriptwriting->Script Settings. Increased the Right Margin, but this had no effect.

Is there a way to do this?

I’m using Courier Final Draft font – don’t know if that matters.

Thanks in advance!

One thing you could try is ticking “Use default Final Draft screenplay elements” in the “Script Settings” pane of Compile. This causes Scrivener not to include the details for how to format each element in the FDX file, which causes Final Draft to use its own default formatting for each element.

Thanks KB,

If I understand the above correctly, it would cause Scrivener to override final draft’s formatting, right? I actually want to preserve the FD formatting. I’d like to tweak Scrivener’s just a little to match it.

Thanks again.


No, the opposite. When “Use default Final Draft screenplay elements” is ticked, Scrivener outputs the formatting into the FDX file, so that Final Draft uses that. If you un-tick “Use default…”, then Scrivener doesn’t include any formatting information in the FDX file at all, meaning that Final Draft will use its own default formatting, which is what you are after if I understand correctly.

The quickest way to see what I mean is just to try what I suggested. :slight_smile:

Wow. This didn’t actually solve my problem, but it sure made my day. Compiling with the option you suggested shaved over ten pages off what was a 131 page script. I hadn’t even noticed the broader spacing Scrivener was creating. Huge huge huge.

For what its worth, this didn’t change the text width in Scrivener, though. I didn’t check every element (dialog, wrylies, etc) in FD, but it didn’t change the width of action there (which is good).

I’m not sure if I’m being clear… if I were using Word (heaven forbid), to make the same change I’m looking for here, I’d go up to the ruler and move the right margin arrow out just slightly until one more character would fit on a line of text. I thought the same might work in Scrivener, but I can’t move that margin marker to the right. It will move to the left. I suppose I could just cheat the left margin over until the action lines are as wide as I’d like, since that formatting will be overridden by FD.

It’s not a big deal if this is a hassle. I just thought I’d ask. And I’m so glad it led to the other formatting discovery. Thanks!

Sorry, I thought you were only looking to change it so that it looked right in Final Draft - I had misunderstood and didn’t realise you were trying to get it to look the same in Scrivener!

Although you can certainly change the formatting using the ruler in Scrivener, that won’t give you the desired result, as it will only affect the selected paragraph and it will make it so the paragraph is no longer recognised as a script element (since recognising script elements depends on formatting). Instead, you can edit the screenplay settings via Format > Scriptwriting > Script Settings. There you can change the right margin, line spacing and so on, for the script format.

However, the “Screenplay” script format is already set up to closely resemble the Final Draft formatting, so I’m not sure how much closer you’ll be able to get it (are you using the “Screenplay” format and not the old “Screenplay (Final Draft)” format that is a hangover from Scrivener 1.x?).

One thing to bear in mind is that differences in the text rendering engines will mean that the text will never appear identical across both programs. I’m surprised so many pages were shaved off, though, because, as I say, “Screenplay” format is supposed to be fairly close to the default Final Draft formatting.

All the best,

These are contradictory. I am pretty sure the first one is the correct story.

Oops, yep, you’re right. That should have read “When ‘Use default Final Draft screenplay elements’ is un-ticked, Scrivener… If you tick ‘Use default…’” Thanks for the catch.