Hunting down first line indent problem

Hello! I am compiling my project, and for the Section Layout for most of the documents in the project, I’ve specified “Remove from first paragraph and after empty lines.”

Right now I’m looking at chapters 11 and 12. As far as I can tell, they’re formatted exactly the same. Both are section type Chapter, and that section type is assigned the proper section layout. Both look identical in the editor, and I’ve run Convert to Default Formatting on both of them. Neither chapter has any styles applied to the text. The section layout has a “Override text and notes format,” if that matters (I tried turning it off and it didn’t fix the issue).

When I compile, Chapter 11 has the paragraph indents removed in the proper places. Chapter 12 does not. In fact, Chapter 12 seems to be following the ruler settings in the editor, because if I adjust the paragraph indent marker in the ruler, it affects the output.

It seems like there must be some place in the inspector for Chapter 12 that is saying, “Ruler overrides section layout,” but I don’t know of such an option. Any ideas? Thanks!

How each document is treated on compile is the result of i) its Section Type and ii) the Section Layout assigned to that type in your compile settings.

Are the two chapter docs assigned to the same Section Type? If Chapter 12 was assigned to an As-Is section type, that would make the difference. Cf. Inspector > metadata tab > Section Type.


Both are assigned the same section type (Chapter).

Is it possible that you have manually entered tabs in one of the chapters?

… if not, you need to show us the compile screens.

Here are two screens from the compile process. What else could I post that would be helpful?

Main compile screen:
Section formats:

What else…
The beginning of both chapters with ”Show invisibles".
… in the Editor

Here you go! (I lorem ipsumed the text, but confirmed that the issue remains.)

Chapter 11:
Chapter 12:

Chapter 11 is the one that compiles correctly; Chapter 12 is the one that ignores the “remove indent from first paragraph and after blank lines” directive. Thanks again.

My guess…
As both are text documents Scrivener sees Chapter 12 as a continuation of chapter 11 and it hence doesn’t have a first paragraph. In spite of the heading

Good guess! But it doesn’t work.

If I export the whole manuscript, it looks fine up until Chapter 12, even though there are many adjacent text documents. Furthermore, the problem lasts throughout Chapter 12; there are many blank lines between sections, but no indents are removed.

Have you tried to create a new document, copy the text in chapter 12 and paste it with match formatting?

You probably has something in there that you can’t ser that is causing the problem.

Or Paste into TextEdit and then do the copy-paste with match formatting etc into the new document.

SInce most recent upgrade Compile has removed all first line indents for me. I have text set to compile as is, and have had no trouble in the past keeping indents that appear in the text.
Now however Compile removes all indents and removes all blank lines between paras (eg sometimes I leave a para space before and after a para to ‘highlight’ it for editing purposes, but now these are removed)
And ideas?

Bingo–that solved it! Thank you!

Now, I’d still love to figure out what was causing the problem…

APH, is it possible you’re compiling to MultiMarkdown?

Sometimes there are things hidden in the text that won’t be shown even by Show invisibles.