I am absolutely livid... No, I am an absolute idiot


I worked on my novel this morning, saved it and compiled it (as a backup) like I usually do. I also checked my word count. That had reached 73,000 the day before. Today it was 67,000. I then went through the text and great chunks were missing. It was as if the last save has gone back to a save that existed a week ago. I have lost at least 6,000 words, six days work. Even compiling hasn’t saved me as that contains the same version.

Man, that sucks.

I had a bout of low productivity during the release life of 022 and I didn’t bother to update to 023. I worked on tweaking about four or five chapters and subsequently found that changes to two of them had not been saved. I was a bit put out at the loss but also relieved that it wasn’t greater.

Six thousand words is a huge blow, but you’ll get them back, and some bits might even be a bit better given that you’ve written them once already :slight_smile:


I’m so sorry about the loss of your work. Did you do a clean install of 024 or did you 024 on top of 022. 022 had a known saving bug and it’s possible some 022 files still remain.

To ensure that you have a clean copy of 024:

  1. Uninstall Scrivener.
  2. Find installation directory.
  3. Delete any remaining files that may still be there.
  4. Install Scrivener 024.

This should prevent the saving bug from occurring again. I’m sorry that you’ve experienced this bug.


I am sincerely sorry for the loss of your work. We do everything we can to ensure that the betas are sound. We have not reproduced this at all in testing, nor has anyone else reported this, so if you could provide any further details about your computer and install process, as covered in bounty hunt post, I would greatly appreciate it.

That said, have you verified that the project you’re working in is definitely your most recent version? Since the 024 update unintentionally cleared the “recent projects” list, you would have had to go open the project by finding the location on disk, and I know that at least two people accidentally had this same problem: they opened an older backup (that had the same title) or discovered that for a while prior to this they had been unintentionally working in a backup copy rather than the main copy. The symptoms sound exactly as you describe (which is not quite the same as the non-save bug), with “random chunks” that would cover days of work gone missing, but the work was actually just in a different project than the one they’d opened.

Try running a Windows search for some unique words or phrases in the sections you’re missing. If you find the documents (they’ll be just numbered .rtf files) you can look at “more search results” if necessary to see the file path for the .scriv folder containing them.

Just to share something from another thread. There is something that goes on with file names… I’m sure someone here can explain better than I… but one person pointed out that they thought they had lost a great deal of text only to open a new text file, and it auto-populated with the text they thought they had lost (as I said, something was going on with the scrivener rtf file names behind the scenes).

The point is the text was still there. Before you give up hope, maybe you could do a windows search, searching within the files of the project directory for some phrase you are sure used to be there but now is missing. 6000 words is a lot, so if that information is still out there it’s worth looking for.

Good luck!


MM beat me to it. Should have read her post more carefully!


I had left my 022-based project open for days awaiting the moment when I had my current novel notes completed. I had really only added about 200 words or so to the bottom of the “Notes” document that was the dump for ideas as they occurred to me. When I thought I was at a “logical stopping place”, I would carefully upgrade to 024.

And then this morning, I had an idea for a short story. I went through my process to set up a new folder in my SVN repository. Okay, done. Then I created a new Scrivener project to start the short story. Okay, done.

And then I noticed that the old, crufty, up-for-weeks novel project was still open. So I closed that. Then I went back to…

Wait… Oh, no. I didn’t compile the novel project before I closed it, did I?


That probably means I lost those last 200 words, doesn’t it?


They’re gone, forever, aren’t they? (I check the .rtf files in the project folder.) Yep, gone forever.

But I’ll remember those 200 or so precious words about the final encounter between the pro and antagonist. Those bits of crafted dialog. And the overall carefully mapped out reason why the protagonist now has the capability to overcome the antagonist – I’ll remember that, too. Won’t I? Please, tell me I won’t have to try to recreate that logic, those notes. Please? That’s why I wrote it down as soon as it came to me. That’s why I ran, yes, ran to the computer as quickly as I could. Because it came straight from my Muse that morning. And now, after all these days, it is gone in the Mist, as are all such ephemeral things that occur to me just as I wake up, while I’m still half dreaming.

I guess there is hope. But right now, that’s all there is.

My fault.

Upgrading to 024.



Also incredibly sorry to hear that you’ve lost work. I gather from your post you’ve already looked at the document files themselves and confirmed that they’re missing the text and that there aren’t backups or such. It sounds like you were still using beta 022? The update to 024 should fix the non-save bug from that version (and you can do a thorough uninstall of 022 if you like and reinstall 024 fresh, although the installer for 024 is more robust so this isn’t strictly necessary) although I realize that’s not going to help you with the missing words. For future reference, updating the program will require that you close projects and restart, so leaving the project open isn’t really a way around the problem. In any case, I’m truly sorry and I wish you the best with recovering your ideas; I hope the new ones will be even better.

Actually, the problem you’re describing is different from the one I mentioned, so thanks for bringing that up. That issue where text is gone and then “magically” reappears when you create a new document is due to the .scrivx file getting corrupted or otherwise being out of sync with the rest of the project–usually the cause of this is (as in the case posted the other day) a conflict caused by a sync service like Dropbox. If the project doesn’t get updated fully to the Dropbox server and synced properly to the second machine, you can get “conflicted” files. Dropbox keeps these, which is great so you don’t lose work, but it means that you can get weird stuff happening in the project since some of your files are the wrong version. They’re all still there, but some of them aren’t being seen by the .scrivx that the project is using to create your binder and organize everything.

It’s fixable, though, and definitely it’s worth taking a look in the .scriv folder and seeing if there are any files with a name like “conflicted copy” tacked on the end.

hardycapo, I keep thinking on this one, don’t give up on the lost text until you have really assured it’s gone. If it were mine, and regarding what others have said in the thread as well, I would:

  • have a very careful look through all RTF files within the project.scriv/Files/Docs folder. You can use Word (or OpenOffice) to open each one, and see what’s actually in it. Obvious renames from the pure numeric sequences are especial places to look.

  • If you have a version of Windows that supports it, right-mouse each of those RTF files and select Preferences, then use the Previous Versions tab usually the far-right tab) and see if there are any. These are ‘shadow copies’ which are kept by the NTFS file system of earlier writes of files, until their space needs to be over-written.

  • failing these, there are a myriad of file recovery programs which will diligently investigate your disk and try to recover full or possibly fragments of deleted files – I believe this will also cover over-written files except in special cases. I’ve had success at this before, and the following got good marks, is done by a programmer in Germany, where such utilities are often just very well constructed, and free as this one is.

The company which offers it is professional and certified at the expensive hardware data recovery, which is another definite plus point, besides their assurances about handling difficult file cases:http://www.pcinspector.de/default.htm?language=1.

  • For any of these methods, please be sure to have connected an extra disk or USB memory to put recovered files or fragments on. You want to minimize anything added to the original disk before recovery, as sooner or later this will over-write the obsolete copies.

Best fortune, hardycapo. I hope some of this may work for you.


Thank you everybody for your kind words and tips. It’s very much appreciated. I shall try some of these methods.

Sorry to hear of your woes …

Do let us know how you get on … Some of this missing work might just be hiding somewhere unexpected.

hardycapo, excellent, and you can be sure many of us are with you on this.

Here’s an addition to my second tip above, about finding any shadow copies held of previous RTF files from Scrivener. I’d thought to remember a tool which will let you access these even if you have a Home version of Vista or Windows 7 – and this morning found it.

Note that this can only work on Vista or Windows 7 (or certain earlier Windows Server releases), as previous versions of Windows didn’t automatically enable the shadow copying feature. It’s intended to let you use the feature even if you have one of the (most common) Home versions of these.

Here’s the tool, and I cross-checked it with Norton local and network to be confident enough it’s safe, since download.com doesnt offer it: http://www.shadowexplorer.com/downloads.html

Here are some decent instructions on how to use this tool after you’ve installed it, along with some confidence-building comments: http://www.howtogeek.com/howto/windows-vista/recover-files-with-shadow-copies-on-any-version-of-windows-vista/

Ok, and the only other thing I thought might be helpful is to remember to set that you are looking for RTF files only, when using a file recovery program as in step 3 above. This focuses on the file type you need from Scrivener, making things easier both for you and for the tool.

Good fortune, and I hope your patience uncovers something.



Excellent news; thanks for reporting back! Like I said above, other people had this too, and when you’re looking at a project missing a week’s worth of work, it’s easy to panic! I’m just glad it’s all really still there. :slight_smile:

Mine did this as well. I clicked on the scriv. icon and it opened an older version. I admit I paniced for a moment before opening another version of my file.

Might it have been a quirk?

By default, when Scrivener launches it will automatically open the most recently opened project, so it’s possible, depending what you were doing in Scrivener last, that the older version could’ve been the more recently opened one and thus the one that Scrivener would automatically open on start up. If you do a “Save As” or a “Backup” from Scrivener, the auto-load would still remember the current, newer version, but maybe you’d opened the older version to view something? The only other way I can think of this happening is if the older version had the same name and file path as the newer version, but that would mean that you’d have to have renamed or moved the projects while Scrivener was closed, which seems like something you’d remember doing. :wink:

actually, I didn’t find the new update for a few days, as life had been crazy here, when I did, I still had open the current file I was working on (ever week or two I save as and rename the file and work from the new name, creating several saving points should something go wrong) and went to Help>check for updates, when it told me there was a new update installed and it opened an older file (only on my Win 7 computer, this didn’t happen with Win XP.)
The older file was several save versions ago, HOWEVER. it was the last save version before I went to dropbox. Once I pointed it back to dropbox it has had no trouble finding it. just that first time it reverted back to the verson on my hard drive. I’ve noticed that there’s some dropbox issue, I’m not having any (this may be because I’m careful to close scrive on one pc before opening it on another) but I hope that helps.

Hum. The 024 update wiped some settings it shouldn’t have (including the recent projects list), so my guess is that it’s related to that then, although it’s still definitely an odd thing. Did the file it opened have the same name as the one that you had open when you ran the update? (But stored in a different location on your drive.) I suppose it could’ve confused the file path when it reverted to defaults, although obviously it shouldn’t have. Curious. Thanks for the report.

The previous draft does have a different name. To be honest I’m not sure what happened. I don’t remember going back to the previous draft before upgrading. My vague recollection is that I upgraded, then began work again, not realising I was working on the previous draft. But I can’t guarantee that’s actually what happened.

I’m just glad my confidence in Scrivener is restored as there is I haven’t found any other software that does the job as well.

Hardy, I hadn’t understood your revised posts when I added more ideas for getting lost things back.

Just very glad to hear you retrieved your work, as I know writing of that kind never turns out the same a second time, unless you are just lucky to recall what you did.

And yes, taking a wrong turn on version names happens to us all once in a while.

Two goods from further discussion, I think:
– at least we have some how-to-find-missing-files suggestions which I think are pretty sound
– the issue with 024 happening to clear all presets is probably better highlighted and understood, as Jennifer notes, so that it won’t happen again.

I think we are all enjoying the writing with Scrivener, and a good thought your direction as you get back with it.