I can’t seem to make a functioning ToC anymore


I used to be able to make a table of contents in Scrivener, and then compile that within a PDF or RTF. I don’t seem to be able to do it anymore.

  • I selected all the chapters of my novel (using selecting the first one, then shift+selecting the last one),
  • I used Special Copy > Copy as TOC
  • I made a blank page, which I dragged right behind the title page.
  • I pasted the TOC on there.
    Now it looks like a list of hyperlinks, neatly organized in a hierarchy, but with <$p> instead of a page number
  • Now I try to compile. I’ve paid extra attention to the Export Converters under Tools > Options > Import/Export > Export converters. I’ve tried both RTF-based and Microsoft Office 2007-2016.
    -It just doesn’t compile correctly. Not only are there either question marks or number 2 (the page on which the TOC is presented), but also, the hierarchy in the list is just flattened into a single list. I have a hierarchy with Books - Parts - Chapters, and so it shows in the TOC that I special copied in Scrivener, but it’s all gone after compiling

I’ve asked questions about ToC before, but then things eventually worked. Now I seem really stuck.

After faking a print within Word, the page numbers in the TOC are back, but, the outlining is really weird. It wasn’t like this before. I want the normal layout of the ToC when it’s Special Copied in Scrivener, before the Compiling.

How do I fix this?

…while this is how it should be, with a nice hierarchy, instead of a (vertically) flattened list.

They only workaround right now seems to Compile the ToC as-is, but then I have to change the font and layout manually

I’ve finally finished my novel, and I need to compile tonight, but I only get page nr. 2’s all along the list (that’s the page on which the ToC is located). I’ve deleted it and remade it, using RTF en word, but to no avail. Can someone help me out here?

All the links in the ToC work perfectly: they take me to the corresponding chapter. So why doesn’t it work with compiling to RTF/DOC/DOCX?

I finally managed on another computer where I used a newer version of MS Word on the compiled RTF. Is this a known issue? That the ToC generated in Scrivener works (better) in Word 2016 instead of 2013? Or is it a setting within Word that I’ve overlooked, that causes only page 2 to show up in the ToC?

Today I thought I’d try making a ToC in Scrivener for Windows. I followed the instructions in the manual. But all I get after compiling is what looks like a template ToC with <$p> going down the page and # in the corner of each page.

In other words, I’m having the same problem.

Are there better instructions for making ToC somewhere?

Looks like MS Word needs to be installed to even attempt doing ToC generation in Scrivener for Windows. The manual needs updating, or a better explanation of exactly which file formats to use for exporting.