I can't create new projects

Hi all!

I’ve purchased Scrivaner 3 for Windows yesterday. Unfortunately, I cannot create new projects. Every time I try, I select the template I want (which is that for novels), then I click “create” and it asks me to input the name of the project, but when I click “save” an error message shows up saying

“project.scriv” is the main structure file for a project, but other required files for this project could not be found: the \Files\Data folder is missing"

It then proceeds to create a folder with three subfolders (Icons, Settings and Snapshots) but no Files folder. I have noticed that this problem is not present if I choose the blank template, but this kind of stinks because I want to use the novel one :slight_smile: Hope someone will be able to help, I’m not very tech-savvy so it may be something obvious that I’m missing

Ps: I’ve also tried uninstalling and reinstalling but it keeps giving me this error

I don’t use the Windows version of Scrivener, but I’m surprised that there was no drive letter defined in the error message, e.g c:\Files\Data? Is that due to you not giving a drive letter where this might be set in preferences? Or in fact is the folder \Files\Data actually missing on the file system (but without a drive letter I don’t know how that would work). All this just a hunch…

Thanks for the replay. When I installed the program I did give it C, which was the default setting anyway, yet the letter doesn’t show up in the message, if this is what you mean (again, I’m a bit thick when it comes to this stuff)

my best question: does \files\data really exist? only you can check. without drive letter i do not know how that possible on a Windows machine but I think Scrivener probably cannot find what is impossible to find. not a scrivener issue I think, but is caused by what Scrivener was told to do.

The Files folder that is being referred to here wouldn’t be at the system level, but rather within the project itself, along with Settings and any other folders the project needs. The Files subfolder is where all of the data goes, among a few other central indexing files and such. You definitely need that folder, and the stuff within it, for it to be a proper project.

You mentioned Blank working well. That’s actually a good test to do, because there is one important difference between that, and the other fancier templates: the latter are stored as a zipped prefab project in the template file. So when you create a new project from one, it unzips that project and then sets it up in the location of your choosing.

It’s interesting that some of the project unzips correctly but not other parts. That could indicate some kind of permission issue, or maybe with anti-virus software not allowing Scrivener to write the files it needs. Hopefully someone comes along that knows more about those things, but that pointer may be enough help you figure out what is going on.

Thank you both for your answer. I haven’t figure it out yet, perhaps I will contact support in a couple of days if I can’t sort it out. But adding to the mystery, I have strangely been able, yesterday, to create a novel project. Just once, and then it reverted back to giving me that error :smiley:

Do you have an external drive of some sort that you could test creating projects to, or maybe another partition on the same disk, in lieu of that.

Well, guys, don’t ask me why, but it seems to be working, at least for now. Considering my understanding of technology is not too far from “and then some magic happens” I wouldn’t be able to venture a guess as to what changed. Instead of clicking “create” after selecting the template, I double-clicked the template, but I’m pretty sure that was just an apotropaic gesture with no particular effect. I appreciate your help, thanks! :pray:

nice word… :slight_smile:

Is something like it common to use in your location?

Anyway, glad you got the problem solved. And yes, even when you know more, in software there is often enough a sense of magic, one way or another, in what it actually does…!