I can't restore a backup from Dropbox

I’ve had a computer failure and am trying to restore my yesterday’s latest Scrivener Dropbox back up on to a second computer. Whether I try to open the file in Windows or after importing it into Scrivener I get the message that it’s not a Scrivener project file and I should select a valid one. The version of Scrivener on the second computer is and I have Windows 7. I should be very grateful for advice on this.

Sorry to hear about your computer failure!

There are three simple scenarios I can think of that might be causing your error:

  1. The backup on Dropbox is a zipped archive, and you’re trying to open it in Scrivener without having unzipped it first. This is an easy fix; just right-click the zipped folder and choose “Extract All”, extracting it to wherever you want to save your restored project, or double-click the zipped folder and drag out the contained .scriv folder to wherever you want to keep the project. Once you’ve done that, open the extracted project in Scrivener as normal.

  2. If you happened to have copied the project from one location to another (maybe you copied it out of Dropbox on the second computer?), you might have copied only part of project instead of the entire .scriv folder (this is an easy mistake to make on Windows, since all the contents of the project folder are visible, and the “project” file inside the folder is the one you click on to open it). In that case, try again after making a copy of the entire .scriv folder to your new location, or if necessary, restore the “project” .scrivx file into the .scriv folder and then move the whole thing.

  3. If your project was open when the computer crashed, it wouldn’t have closed properly, so you might be working with a corrupt project that’s missing pieces needed to open the project or has them locked and inaccessible. Have you tried an earlier backup? I’d make a copy of all the automatic backups you have (assuming they are somewhere still accessible) and then try going through them backward to see if you can find one that opens. If you get one that works and it turns out the more recent is corrupt, you can open the folder and salvage files from it into the restored older version.

In the case of 3, it may even be possible to salvage the corrupted project, depending on what files are damaged. You could also try creating a new project and using File > Import > Scrivener Project to import the corrupted version; that sometimes works to cleanly import from a project that’s been damaged and give you a good set up for fixing everything up in the new project.

We’ll hope though that it’s just something like 1 or 2 and solved with minimum fuss!

I managed to restore the backup before I’d read your reply though it was as if by accident and didn’t seem to follow any of what you wrote. And I entirely neglected to thank you for your very helpful reply. Meanwhile two years later I’ve had a further computer crash and similar problem in knowing how to restore from backup, but now reading your reply was easily able to do it from suggestion one. I’m extremely grateful for your help and apologise for not having responded at the time.