I Get No Preview

When I select preview from the Print dialogue, my Mac opens the preview app, but no document preview appears. It looks like Scrivener doesn’t create the corresponding PDF. I have tried restarting and rebooting, but the issue persists.

BTW, the version I am using is 3.3.1.

  1. Print outputs whatever is in the Editor pane, so if that is looking empty… (Just leaving no stone unturned here.)

  2. When you invoke Print, do the thumbnail pages in the print dialog box show pages with text or blank pages?

  3. What happens if from the print dialog box you choose Save as PDF instead of choosing Open in Preview? Does the resulting PDF have the expected content or is it blank too? Multiple blank pages?

  4. I am unable to replicate the problem on my Scriv vers 3.2.3 on MacOS Ventura. Maybe its a 3.3.1 thing?

I have macOS 13.3.1 and Scrivener 3.3.1. I don’t see what you report.

With a test document in the editor, I use Menu: Print Current Document … It shows a preview of the document in the box to the left 1/2 of the dialog box. then I pick on the pulldown at bottom next to the “?” “Open in Preview” and it does as instructed, opens the PDF in Preview.

Where are you not seeing the Preview? On the print dialog box and/or Apple Preview app?

I suspect something with your printer driver. I had an issue like this (can’t remember the details) a few months ago with my Brother HL-2350DW and with help from Brother’s Support they provided me with a version of the printer driver different than provided with macOS that fixed the problem. Perhaps try a different printer, and/or check with the vendor of your printer about their compatibility with macOS 13.x

Thank you for your reply. The Preview thing worked perfectly until I installed version 3.3.1, so it could be an issue with that version of Scrivener. I have tried changing to another printer driver, but the “problem” still persists. The printing itself works fine, though, so I assume all will be fixed in a possible version 3.3.2.

Have you tried what @gr suggested?

I guess we have to await others seeing the same issue with this version of Scrivener. I am not seeing it so a mystery.

I’ll reply to your points in sequence:

1: Printing works fine.
2: The thumbnail pages look exactly as they are supposed to.
3: That works as it should.
4: I also suspect it is a tiny bug in 3.3.1. My suggestion is that Scrivener fails to produce the PDF that subsequently gets loaded into the Preview app. No big deal, just a minor nuisance.

It could well be content related, as I don’t see any issues here either with a simple test. I’m including the sample project I used to print, and then load as a print preview in Preview.app.

print_preview_test.zip (77.3 KB)

Does this project work for you? And if so, what steps would you need to take in this sample in order to trigger the problem? It might help to open it up alongside the project you were testing with before, and look for anything that might be different, and then try and replicate that difference in the test project. If you can’t get it to happen at all, copying and pasting from the original might help.

If you can find a way to demonstrate it, then attach your own sample with the modifications.

On the other hand, if this sample does not work at all for you, from the start, then I’d imagine it is some level of machine-specific configuration issue. It is likely unrelated to Scrivener since once you get into the Print dialogue itself, you’re in pure native Mac code.

Thank you very much for your reply. I have made some further tests, and I must – perhaps ashamedly – admit that the problem also persists in Microsoft Word. It looks like it is something to do with the Apple OS. I am running Ventura 3.3.1(a). I suppose I’ll have to wait for a bug fix out of Cupertino. As the print out works like a charm, Scrivener is hereby officially declared innocent of any charges. Mea culpa.


Did you ever get feedback on this from your printer manufacturer’s support? I’m pretty sure it’s the printer driver that creates the preview (in addition to printing).

As far as I can see you haven’t said whether your machine is Intel or Apple Silicon. I’ve checked on my system, which is Apple Silicon and I don’t have the problem. Ventura 13.3.1 (a) here, Scrivener 3.3.1.

Just a thought,