I just cannot get the First line indents to remove for first paragraphs and after empty lines

This advice helped me:

“You haven’t by any chance used a “Normal/Body” style you’ve set up, have you? If so, there’s your problem… all standard text should be “No Style” in the editor, which becomes Normal or Body on compiling. If you have set up a Normal/Body style in the Scrivener editor, it will over-ride any compiler settings”

When I set my text as no style it then correctly indented when compiled.