"Import and Split" and save issue

I’m having issues with saving after Importing and splitting a file

Version:Version: 1.9.16.0 - 14 Nov 2019
Paid or Trial: Version
Windows version: Windows 10 Home

Steps to recreate:

  1. Create a new project
  2. Save to local hardrive
  3. Select Import and Split file
  4. Validate file imports into distinct documents in Scrivener
  5. Press Ctrl+S to save to local harddrive.
  6. Close project
  7. Open project
8) Note that the data imported in step 3 is no longer in the project.

On NYE I decided to to, as part of my trial of Scrivener, to import and split, a list of year end reflection questions. My goal was to import all the questions as separate documents and group them under headings to simplify my ruminations. I did all that and then proceeded to work for a few hours. I returned to the project today. All of my work was lost and none of the questions imported into the the remain.

I researched and attempted to solve the problem myself. I was unable to find a resolution.
I was falling in love with scrivener on NYE. Today, not so much.

Did you use the “Save As” command after you were done working?

The most likely cause of the issue is that you simply opened an older version of the project, before the data was imported.

Katherine

I have tried to save using both ‘Save’ and ‘Save As’ . Both have the same result as the steps above.

You can search for .scriv folders, or for the missing text, using the Windows search function.

If that doesn’t help, are you using One Drive, Dropbox, or a similar service?

Katherine

Hi Katherine,
I am saving this to my local harddrive. I had noted that in the original instructions to recreate, but I may not have made it clear enough.

I did a search and found files from my original NYE writing in 2020 EOY Review.scriv\Files\Docs.

If scrivener saved these files, why don’t I see them when I open that scrivener project? That’s the part that is flummoxing me. Is there an arcane step I’m missing so Scrivener sees the files? Should I be saving the files to a specific place on my harddrive?

Thanks,
Addy

Try using Scrivener’s internal project search to locate the material. If the files are in the right place – which they appear to be – the most likely issue is that you have accidentally enabled a view of the project that doesn’t show them.

If you could send a screenshot of what you’re seeing in the Binder, that would help me determine exactly what might be happening.

Katherine

Are there no documents in the Binder, or are the documents present but you’re not seeing the content in the editor?
Please describe exactly what you mean by “the data … is no longer in the project”. Preferably with screenshots, like Katherine suggested.

Please find 3 screenshots attached. They are labeled in sequentional order (Pic1 -3). The pictures have also been annotated within the picture for to simplify ordering.

The UI is not allowing me to add my fourth file to this responce, or to put all of them in one pdf and upload . I will be adding the fourth in a seperate posts

Screenshot 4

An aside. From a usability standpoint it would have been super helpful to have information about:
-What kinds of attachments I can upload to this forum

  • The allowed size range
    Either explained in the post entry attachments section or in a link to a different page.

It looks as if you’ve just opened a new template. Are you sure you opened the project you created before doing the import?

Please try this:

Create a brand new project. Add a few lines of text. Save it and close Scrivener. Then locate the project in Windows Explorer and re-open it. Confirm that the text is there.

If it is, Import (not split) the file you’re having trouble with. Close Scrivener again. Locate the project in Windows Explorer again, re-open it, and confirm that the text is there.

If both of those tests work, try Import and Splitting into the new project.

Katherine

Hi Katherine
I did all of the above tests.
Everything worked until the test 3 ( If both of those tests work, try Import and Splitting into the new project. )I got the same I listed in the same result as before.

So I at least have a work around.
Was this how import and split was designed to work or did my weird ability to find obscure bugs without trying rear it’s uhead again?

Thanks
Amy

Definitely not how it’s designed to work. Import and Split should give the same results as the standard Import, just in multiple Binder documents.

In the screenshot you posed upthread, some of the documents do appear to have text. (“Endnotes,” “Title Page,” and “Contents.”) Could you check and see if that’s where the imported text actually ended up?

Katherine

What is the character limit for the name of files?

I was just able to ‘Import and Split’ another file directly into the a new project.
The difference?
No more than 3 words per line.
It imported and split correctly the first time and was available when I reopened it.

The file I tried to import before had data that was much, much longer. If i hit the text limit for character names or some other character limit that might be the issue.

Ok I’m going to turn off my BA brain and go back to writing now.
Thanks for your help!
Amy

Ah ha!

Scrivener uses standardized names for the internal file structure, so it’s not a Mac OS issue. But I don’t know if we’ve tested Binder names as long as some of the samples in your screenshot up above. Also, looking at it again, I notice some non-printable characters – the rectangular boxes – that could be posing a problem for the splitter as well.

I would suggest taking the file from your screenshot (or an excerpt, if the whole file is too big) and doing three things:

  • First, if you use an excerpt, make sure it still fails.
  • Then, add line breaks so that the first line of any section is no more than about three words long. Does that fix it, or does it still fail?
  • If it still fails, remove any non-printable characters you can find.

If you can, it would also be useful to send us a copy of the file for internal testing purposes. You can send it to the support address here: literatureandlatte.com/contact-us

Katherine