Import file created in 1.54, lose script formatting

Great to be able to start working with 2.0 prior to the Nov. 1st release. Thank you!

I imported a file created in 1.54 that has a number of short pieces, including several using “script mode” formatting.

The content was imported, but as text.

To continue working with the screenplay-formatted doc I have to switch to scriptwriting (Format/scriptwriting/script mode) and then manually re-assign character/dialog/action – etc.

Is there a work-around?



Which scriptwriting format were you using in 1.54?

Thanks for the quick response – the docs were all created using “Screenplay”

I have the same thing, also using the Screenplay setting. I wondered if it could be to do with the global Page Setup margin settings conflicting with the Screenwriting>Script Setting?

There also seems to be some inconsistency between the fonts Courier and Courier Final Draft but that might just be something I’ve carried over from 1.54 myself.

Otherwise an utterly excellent release by the way! The new freeform corkboard and stacks are especially mindblowing. Thank you!


First impressions – the new design of 2.0 is wonderful!

Regarding screenplay projects, I’ve had a similar experience. I went through the installation process – and if I remember correctly – I accepted the default choice, whereby it placed an existing screenplay template (the old version from 1.54?) into the Miscellaneous category (there currently are no templates in the Screenplay category). I opened and converted a copy of my 1.54 project and everything seemed hunky dory.

The first thing I noticed was that my original Screenplay documents were using the Courier font (my default setting in 1.54), whereas any new Screenplay doc is using Courier Final Draft. I haven’t quite figured out how to change that yet, as I don’t see any screenplay documentation in the Scrivener Manual (perhaps that is still forthcoming?).

The next thing I noticed was that typing triple periods are always replaced by ellipses, even though in Auto-Correction Preferences “Disable ellipses substitution in script mode” is selected. I also tried un-selecting “Replace triple periods with ellipses”, but with no difference.

At one point, I deleted the screenplay template (mentioned above) that was saved in the Miscellaneous category during the upgrade (I wanted to start from scratch). After re-opening the project, all the lines of text in my Screenplay docs were now set as General Text, instead of the screenplay elements that had been previously assigned to them. I tried selecting Documents > Convert > Script Format… but that has no effect (all lines of text are still set as General Text).

So I’m going to start fresh. Delete the project converted from 1.54 to 2.0 … delete the 1.54 application, the 2.0 application, the User/Library/Application Support/Scrivener folder, and User/Library/Preferences files. That way I can work with a clean installation of 2.0 and see what I find. Or perhaps I should wait until the screenplay templates are finished and available with the upcoming official release of 2.0?

I’ll post more soon.

I deleted everything related to 1.54 and performed a clean install of 2.0.

After creating a new Blank project, I didn’t find anything in Preferences for setting the Screenplay font. But I did find that I could change the font to Courier for each screenplay element by going to Format > Scriptwriting > Script Settings…

After opening/converting a new copy of my 1.54 project, all of the text in Screenplay docs were properly using the screenplay elements again (nothing set to General Text). However, when I went back into Script Settings, I found that the screenplay elements were set to the font Courier Final Draft. So I presume this is set per project? Because when I re-open the Blank project I created, it’s Script Settings are still set to use the Courier font.

Anyway, I’ll just relax and wait until the Scrivener Manual has information regarding screenplay settings, and then get my head wrapped around how things work in 2.0.

Sorry I haven’t got back properly to this thread - there’s a lot to do.

First, disabling ellipses, smart quotes etc in script mode should work fine - I just tried it - although the preference name may have changed internally so you probably just need to set it again; not all settings will come across from 1.x.

Regarding fonts, the scriptwriting font is no longer a preference but is now built into the script settings - there is no longer an option to “use font from preferences” as there was in 1.x, because that was the source of a number of problems. It’s set to use Courier Final Draft if you have it on your system, otherwise Courier, purely because Courier Final Draft is a nicer version of Courier which most scriptwriters are used to, and plays well with Final Draft (although the latter is no big deal). So if you want a different font - Courier - change it in your script settings, and then save out your new script settings for use in other projects using the “Manage…” button in the script settings panel.

The font isn’t used to recognise script elements, so this should have no effect on whether scripts are properly recognised; there may have been some other tweaks between versions that could affect things, though, which I’ll need to check on as soon as I get chance. Please bear with me.


No worries Keith. I was just scratching my head out loud to let the previous posters know someone else was seeing something similar, and moving towards understanding how things are configured in 2.0.

I’m happy to work with Courier Final Draft since that is my ultimate font when exporting to Final Draft. Again, I was just scratching my head as to why I still had Courier in my existing docs, whereas new ones were using Courier Final Draft. I’ll just use Documents > Convert > Script Format to get them all looking the same (the spacing between lines is visibly tighter using Courier Final Draft).

As mentioned before, I completely removed all traces of the 1.54 and 2.0 installations (including preference files), and did a clean install of 2.0. But I am still not getting proper behavior with triple periods in Script Mode. I just looked at this again, but performed a more thorough test with the Auto-Correction Preferences.

I un-selected the first four Substitutions in Auto-Correction Preferences, and tested them individually. When I turn smart quotes on, I get smart quotes while typing, when turned off, no smart quotes. When I turn em-dashes on, I get an em-dash while typing, when turned off, no em-dash. However, when I turn ellipses on and off, the result is always ellipses. This time I looked more closely and observed that when “Replace triple periods with ellipses” is turned on, the ellipses appear instantly when I’ve typed the third period. When “Replace triple periods with ellipses” is turned off, the triple periods are still there after typing the third period – but as soon as I hit the space bar, there is a brief pause and then they convert to ellipses.

I then re-selected the first four Substitutions so that smart quotes, em-dashes, and ellipses would be used as substitutions – but would be disabled in Script Mode. This was the default setup from the 2.0 installation. With these all selected – no smart quotes or em-dashes are created – but triple periods convert into an ellipses (after I hit the space bar, followed by a brief pause).

So something is still amiss here in San Francisco. I wonder if anybody else can confirm this behavior on their installation, or whether it is unique to mine for some strange reason?


Someone posted about the ellipses problem in the Bug Hunt forum, but others haven’t been able to reproduce it, so maybe check that out and see if you can add any more info?


Thanks for the heads up. I’ll head over and contribute what I can.

Argh! I had a nice long post here, but either my internet is wonky or the forums are acting up. I’ll try and reconstruct briefly:

Has there been any progress in figuring out why a screenplay/script project imported from 1.54 strips out all of the formatting elements? I brought my script into 2.0 and everything got set to “General Text”. I can switch to Script Mode and add new stuff with the elements set correctly, but given that I’m working revisions, that is at best marginally useful. Given that I’m revising a feature-length (120+ pages) script, going through and manually resetting the elements isn’t really a viable option.

Ok, so I did some experimenting, figured I’d report back with what I found. Alas, it wasn’t much.

The main thing was trying Script-O-Matic’s “delete everything and start from scratch” method. Deleted 1.54, 2.0, /Application Support/Scrivener and the various preference files. Unfortunately, it didn’t work for me. I’m still stuck with my entire project in “General Text”.

One strange thing I noticed was that a decent number of my scenes weren’t actually importing in Script Mode. (Took me longer than it should have to figure out what the yellow text item icons in the binder meant. It’s been a long day.) Hard to say whether that’s just another symptom of the funky import or something with those particular scenes is causing the hiccups. There’s nothing special about them as far as I can tell.

So, anyways, I’m still stuck here. I can, obviously, get my script into 2.0 by bouncing it to RTF/FDX/whatever, but that seems counterproductive. I would lose my scene breaks, my snapshots (Oh, I’ve got 3 or 4 snapshots on each scene, if that sparks any ideas) and whatnot. Much as I want to move to 2.0, it’s looking like I’m going to have to stick with 1.54 for the moment, unless someone’s got a brilliant notion about what’s wrong.

Sorry, haven’t had chance to look at this yet. Some of the settings have changed, so that may be the problem. I’ll take a look tomorrow.

Any further thoughts on this problem? I’ve been kinda banging my head against the wall. While on one hand it’s not the end of the world, since I can keep doing my edits in 1.54, there are a couple of the new features in 2.0 that would make my revisions much less painful.