Import from Tinderbox 5.11.2) to Scrivener 2.3

I’m trying to get Tinderbox and Scrivener to play nicely – in particular, working with my outline structure in Tinderbox and importing this structure into Scrivener.

I have got on top of the Tinderbox export process. Note this (new) very helpful resource which came via the Tinderbox forum:

When I import the .opml file generated by the Tinderbox export process into my Scrivener binder, and open it up, I see a page of .html.

I am expecting to see my outline structure rendered as plain text.

Any insights that could help me out here?

Hmm, strange - it should work fine, as long as the OPML file has the “.opml” extension. One but that crept into 2.2 is that you won’t be able to drag .opml files into the Draft folder unless you add “opml” to the “Plain Text Import Types” under the Import/Export preferences, but this shouldn’t cause it to come in as HTML. Could you please send me a sample OPML file that exhibits this problem when dragged in?


Here it is Keith


21cc interim trs (1.23 KB)

Hi Ian,

That’s not a valid OPML file. If you open it up in a plain text editor, you will see that it is a very messed-up HTML file, with lots of different and sections. This is why Scrivener is having problems reading the file. You may need to double-check your Tinderbox export settings.

All the best,

That’s rather what I thought. Thanks, Keith – I’ll work on the Tinderbox export end.

21cc interim trs (1.3 KB)

I’ve checked the Tinderbox end, done a bit of housekeeping and reinstalled the templates. It produces a html-like export with a .opml header which is pretty much how it should be (according to those in the know at Tinderbox).

Strangely, I can’t get Scrivener to recognise or parse the .opml so the text appears with its tags and higher ascii substitutions.

I have imported this export file (latest attempt attached above) successfully into OmniOutliner.

That might give some clues as to what to look at next?


I dropped the cleaned-up exported file onto a Scrivener binder (Research in a new blank project) and it did import just fine.

Have worked it out now. For benefit of others, i:

• Selected New Html View in Tinderbox
• Selected the Scrivener template (which I had installed earlier)
• Exported (in my instance, to Dropbox). It showed as .opml file in Dropbox.
• Brought Scrivener to front
• Dragged .opml file from Dropbox on to Scrivener binder

Learning point: In Scrivener, IMPORTING and DROPPING ON TO BINDER mean two different things and have quite different actions on the file being brought in.

No, this isn’t true - dragging files into the binder and using File > Import > Files… do exactly the same thing. What exactly do you mean by “importing” - what are the exact steps you were using to try to “import”? (One thing to note, as I mentioned in my first reply, is that a bug in 2.3 is that you have have to add “opml” to the “Plain Text Import Types” in the Import/Export preferences to allow OPML files to import into the Draft folder, but that applies to dragging too.)

I meant what you said i.e. File > Import > Files. I needed to select the MultiMarkdown option for it to recognise the .opml file to be imported.

At that point the import took place. When the imported .opml file was opened in Scrivener, the original Tinderbox notes appeared as one item in tagged html-like form.

By comparison, when I dragged and dropped the .opml file on to the Binder in the left-hand pane, the contents of the file appeared as four separate notes representing the notes’ headings, and the content of each note attached – not sure if it was in the form of body text or an annotation. All recognised and clean though.

Did you add “opml” to the “Plain Text Import Types” as I suggested? As I said, if you don’t do that, then File > Import > Files… will refuse to open the OPML file if the selection is in the Draft folder. Other than that one bug, which I mentioned, it definitely works. :slight_smile:

In Preferences, Import?

Found it and added opml to list now, thanks

Bottom line: It all works! How good is that!

Excellent. :slight_smile: As I say, this bug is fixed for the next update, it just crept through into 2.3 - you shouldn’t have to add the extension to the plain text import types really, it’s just a a workaround for now. Glad it’s working, though!