Importing AND Compiling Word

I updated to 029 on my desktop last night and was overjoyed that I could now import .doc and .docx files into Scriv AND compile .docx files. Woot.

Then I updated to 029 in my laptop, where I have gobs of files I want to import into a different projects. Alas, when I drag and drop or when I do File->Import, all I get is the gray screen with a hyperlink to the file. This happens with both .doc and .docx files. And when I try to compile .docx I get “unspecified error”.

The only difference is the desktop (where it works) is 64-bit MS Office, and the laptop where it doesn’t work has 32-bit MS Office.

I tried completely uninstalling Scrivener, including doing a registry scan, moved my files and re-installed. Still will not import documents correctly, nor compile. It’s really frustrating that it works on one computer and not the other–especially since the “other” is my main work computer.

Any ideas?

Ok. Did more experiments, and Scriv will definitely import .txt and .rtf docs fine. Still leaves the fact that it hates my 32-bit Word and its files. I even tried to import a .doc file not created on this machine. No go.

Sorry about this. I’m afraid I don’t have a real answer for you at the moment, but I wanted to let you know I did see your post here and I’ve forwarded the information on to Lee and am waiting to hear back about the Word requirements. I was under the impression that it was only the date of the program that made an issue (Word 2007 and up for .docx) so I’m not sure why the 32-bit vs 64-bit is making a difference or why .doc isn’t working at all. The issue will be to do with Scrivener not finding the tools it needs from the installed version of Word to do the conversion, so it won’t matter where you created the .doc file you’re trying to import. The only workaround I can suggest now, other than converting the documents to .rtf, is to transfer your project to the other computer and import the files there, then bring it back to your laptop. Not elegant, I realize. I’ll let you know what I hear back from Lee.

I can tentatively confirm this. Windows 7 32-bit on a netbook, using Office 2010, and the .docx file comes in without an icon and are treated as an unsupported file (external editing available via the hyperlink). Spartachris , are you using Office 2010 as well (I’m assuming yes, since I don’t think the older versions came in 64 bit)?

Yes, using Office 2010, Windows 7, 64-bit. And I confirmed the problem with Office 2010 32-bit:

On the affected machine I uninstalled Office 2010 32-bit and installed 64-bit Office. Scrivener imports now! AND it compiles to .docx too. So the problem is the 32-bit Office 2010 on the 64-bit Win7.

Whew! Glad I am able to move forward on my project—and help Scriv at the same time. Thanks for the confirmation and response, MM and AmberV!!


Great! Thanks for verifying that this was the cause. It might have just be re-installation in general that fixed a broken pathway, but I bet it’s the bits at the root of it. I think the “pathway” is fairly passive in nature.