Importing .docx and .pdf not working - get error messages

I use Scrivener for Windows, and I’ve tried importing .docx and .pdf files as described in the manual. Whenever I select File --> Import --> Files… a window pops up but only shows the .docx files, it is not picking up my .pdf files. But even when I select a .docx file and select open, a “XML Reader Error” window pops up, followed by a “Could Not Convert File” window. Before I even tried using Scrivener for the first time, I tried the same steps and it worked fine, giving me confidence to use Scrivener. Now, when I go back to try to import other chapters from the same Google Docs source as I used the first time, I get these errors. Very discouraging. I’ve tried several different ways, including Copy/Paste and Copy/Paste and Match Style, to try to get my old chapters into Scrivener, but nothing is working. Any ideas out there to help me feel good about Scrivener. Up until now, I’ve loved Scrivener. Right now, I cannot go forward until I can get the rest of my chapters imported. Rewriting everything is not an option. I’d appreciate any help to knock down this roadblock.

If PDFs aren’t showing up, it sounds as though you’re importing into the Draft folder. The Draft folder can only contain text files. It may be renamed “Manuscript” or something else in your project, but it should have this icon:Draft.png
Make sure you’ve selected somewhere outside the Draft in the binder before choosing File > Import > Files… The PDFs and other media files should then be available.

The DOCX import error could be a result of the converters used, so you can try changing this in the Import/Export tab of Tools > Options. Click “Import Converters”, then select DOCX from the drop-down on the left and choose an alternative converter from the list on the left–I’d suggest “Scrivener” if “Microsoft Office” is already in use. Then click OK a couple times to close out and try the import again.

However, the error you’re getting sounds a lot like one that occurs when certain special characters are in the file path of the import file, and these break on all the text imports other than RTF. A lot of Polish characters seem to cause this, but there are others. We are still hunting a solution to the problem, but meanwhile you’ll need to either change the file path to avoid these characters (easier if they’re just in the file name and not, e.g., your Windows username) or re-save the file to RTF and import that.

MM: Thanks once again. I followed your instructions. The Import Converter it was using was “Scrivener”, but there was another selection “Doc2Any.” I changed it to Doc2Any and now my imports work just fine. I’ve imported all of my chapters from Google Docs, so I’m off and writing once again. Thank you for knocking down that roadblock. I am curious why Scrivener’s wouldn’t work but Doc2Any does. I’m not really sure where Doc2Any even comes from, except it was in the Import Converter choices.