Importing images question

I really apologize if someone has asked this question before-- I did look through the forum and couldn’t seem to find anything quite like the problem I’m experiencing. I’m a new Scrivener user, having just received a copy for Christmas. I’m running the program on Windows 7, and while it is mostly running smoothly and I’m really loving it, I’m having issues with importing images…

All of my image files are .jpegs, but for some odd reason, when I imported a batch of them to the Research folder, only some of them showed up. I noticed this when I was on the corkboard. Only some of the images are displayed, while the rest only have the title, and there is no image, even when I try to open them with the editor. I tried to use the option to drag images into the inspector, but it seems to have no effect. What’s stranger, after I opened one of the images to edit the document notes and then went back to the corkboard, the image had disappeared, almost as though it had been deleted, like the others. Re-importing the pictures also doesn’t seem to work. Please help!

I haven’t heard of anything like this before, but given that reimporting the graphics causes the same thing to happen, I would suspect the JPEGs have something about them that our image display library cannot handle. Do you know anything about the provenance of these images? Could you zip up a few of them and attach them to a response so they can be tested on other systems?

One other question: if you use Ctrl-F5 to open the picture in an external editor, does it work?

I’ve had this problem in other programs before - I don’t know if it’s the same thing that’s happening here, but in that case it turned out that the image files had the wrong file suffix applied - ie, they were .pngs that had somehow had the suffix changed to .jpeg or .gif or vice versa. Some programs would open them fine because they looked at the coding rather than the suffix to determine type and then reacted accordingly, but some couldn’t because they were trying to decrypt the .png format with .jpeg code - which, of course, didn’t work. In those cases, changing the suffix worked to fix the problem.

That’s a good point, I didn’t try testing that, so I just did and it looks like Scrivener is one of those programs that relies upon the extension. So incorrect extensions can cause it to malfunction. That still doesn’t explain the one you said worked one but then not a second time. That’s the curious part of this.

Assuming the extension isn’t the problem, is there any other pattern distinguishing the images that don’t import from those that do? Are they particularly large files?

I’m a completely technically backward writer and am using Scrivener on trial.

No matter, it should still work for me even if I don’t understand the more complex hieroglyphics and miss out on more complex functions.

But importing web pages, images or text, simply doesn’t work. It just don’t. No, says Scrivener, I’m struggling to import EVERY webpage. In every given format for importing - plain text, pdf etc.

“No more switching between multiple applications to refer to research files: keep all of your background material—images, PDF files, movies, web pages, sound files—right inside Scrivener. And unlike other programs that only let you view one document at a time, in Scrivener you can split the editor to view research in one pane while composing your text right alongside it in another. Transcribe an interview or conversation, make notes on an image or article, or just refer back to another chapter, all without leaving the document you’re working on.”

This promise only appears to be true with a lot of effort and tech know-how which I don’t possess.

I accept that Scrivener is essentially a writer’s draft programme, but then this promise shouldn’t be made so glibly, n’est-ce pas?

Nothing in the promise above prepares you for the very likely possibility that you simply won’t be able to import web page material if you’re not a fairly advanced techno individual. SAD AND DISAPPOINTED

…What’s advanced about it? You click the import button, select webpage (or file) or from the drop down menu, paste in the url and… it does it?

I’m honestly not seeing where technical ability comes into it. The only finnicky bit is that it won’t let you import into the manuscript/draft folder (because it can’t compile them out), so you need to click into the Research folder - or any part of the binder not in the manuscript/draft folder will work as well.