Importing tables from Word

I’ve recently started working with tables in Scrivener, and I need to make quite a lot of changes to which cells have borders. I find Scrivener’s interface for this quite time-consuming, so I thought I’d try making the table in Word – which has much more flexible table support – then importing the table into Scrivener. Unfortunately Scrivener adds a border to every cell on import.

I’ve attached a shot of a sample Word file with a table formatted in the way I want, and another from a test Scrivener project with the table imported which shows the result. Although the borders I set have come through, Scrivener has added to them.

Is there a way to make Scrivener respect the formatting of the table coming from Word?

Word table:

After import into Scrivener:

The imported table is formatted correctly. The light gray lines aren’t borders, they’re just a shadow grid showing where the table cells are. View -> Text Editing -> Hide Invisibles to make them go away.

(Be aware, though, that showing Invisibles can be very helpful for troubleshooting, for instance if you’ve inadvertently added text to a table and can’t figure out why it’s confined to a narrow column.)


Thanks for the reply. But if I do View -> Text Editing -> Hide Invisibles, the lines don’t disappear, and if I compile the document, say to PDF, the lines show up there too. So they do look like borders.

This is confirmed if I select the whole table and choose Format > Table > Borders > Remove all borders. Then the grey lines disappear.


Do you see the same behavior if you copy and paste the table from Word into TextEdit?


It’s almost the same. When I paste the table into TextEdit, the grey lines appear as they do in Scrivener but the borders I added in Word don’t appear. Screenshot below, and the grey lines will print from TextEdit. Does this suggest that it’s something about the data that Word is exporting that causes the extra borders?

Screen Shot 2019-08-22 at 09.51.26.png

I asked you to test TextEdit because it uses the same Mac OS text system that Scrivener does, and some of the same format converters. Having the problem appear in TextEdit confirms that Scrivener itself isn’t doing it, but not whether Word or Apple is responsible.

Please try two things:

First, save the file to RTF from within Word, and then import into Scrivener. RTF is Scrivener’s native format, so doing the conversion in Word takes Apple’s file converters out of the picture.

Then, go to the Scrivener -> Preferences -> Sharing -> Conversion pane, and uncheck the box to “use enhanced converters.” If you do that, then import the file in Word format, what happens?

(Unchecking the box will use an alternative converter that we’re beta testing:


Ok, those two procedures give very different results, and one of them is very close to what I hoped would happen to begin with.

Saving to RTF from Word then importing to Scrivener gives the following result, similar to what I’ve seen already:

Screen Shot 2019-08-22 at 17.43.04.png

Switching off enhanced converters produces a much closer result. For some reason the lines are of varying thickness, but all the grey lines have gone:

Screen Shot 2019-08-22 at 17.41.52.png


If you could share a test file demonstrating this in the Mac Beta forum, we’d appreciate it.


I’ve just uploaded it to this thread: