Importing Word files w/o annotations

Hello all,

I’ve been using Scrivener to compile multiple (@100) Word documents into a single PDF. The Word docs are collaborative projects that have lots of comments and other markups on them.

How do I import these Word docs without the markups? As it stands, a few random markups seem to “bleed” through onto my imported files. I simply want them to appear as if they were in the no “Markup” view, so that I can compile clean copies.

Thanks in advance for your support!

There isn’t a way to suppress that on the import side, but you can of course handle that on the compile side. Just go into the Footnotes & Comments compile option pane and make sure all inline and inspector comments are stripped out.

Do you also know of any reasons why Scrivener loses some of the formatting from my Word docs when I import them? Almost none of my italics got transferred over.

Does the base font support italics? Word will fake an italic face (by just making the base letters oblique) if the font does not have the variant available.

Interesting…The font is Times New Roman, which is as standard as you can get. How would I find out if a base font supports italics?

TNR is fine. The easiest way to tell if a font doesn’t have italics is to just try. If you select some text and it won’t italicise, then chances are it just has regular or bold variants. The drop-down beside the font family selector on the Format Bar will also give you an indication of what is available. With TNR you have regular, bold, italic and bold+italic.

Hmm, so the thing I’d wonder then is what differences there are between the bits that do work and those that do not, since you said almost all italics are lost. Does the problem persist if you use copy and paste instead of import (I’m not really suggesting that as an alternative—although it works, I’m just curious to see if there is a problem with the importer).

This is really interesting. I just copied and pasted 1 (of the 136!) Word doc into Scrivener and the text that wasn’t italicizing when I imported it is now italicized in Helvetica font. My default font is TNR, so I’m not sure what’s going on. Any suggestions would be greatly appreciated.

Your problem is weird beyond my ken, but here are a couple of stabs at testing things to find a solution:

First, and this is the easiest, try to select all these 136 documents in the binder as one big scrivening, select all (CMD-A) and change the font. I say this is the easiest because if the problem has something to do with fonts, maybe changing the font will restore the italics. That would mean that the underlying formatting of ‘Italic’ is there, but it just doesn’t show up.

Second, try different ways of importing. There are 3 I know of: select the files in Finder and drag them into the binder somewhere, Import Files from the menu into the Draft, and Import Files from the menu into Research (or some other folder besides Draft). Draft is a special folder in Scrivener that restricts what kind of files it lets in.

Copy and paste works, you say – but I would dislike having to open, copy, and paste 136 files… ugh.

Good luck

  • asotir

There is also an entirely different import mode that you can switch to in the Import/Export preferences pane, at the bottom: switch off enhanced converters and then try importing a test file that ordinarily fails. This will use the native Mac OS X converters instead of the built-in Java converter. The formatting quality will drop, there are many very good reasons for why we use a big complicated Java converter over what Apple provides, but I’m curious to see if that is where the problem originates.

One potential clue is Helvetica. That is the underlying default font for the text editor—when it cannot for whatever reason assign the font, or no font is assigned, Helvetica is the fall back. This would seem to indicate that for whatever reason, the manner in which TNR/Italic is declared in the original documents is not compatible with how the Mac text engine recognises font assignments. To this this theory, see if you can open one of these files in TextEdit with the italics still intact.

Thanks everyone for working with me on this!

AmberV, that last option hit the mark. I tried opening a sample Word doc in Text Edit and the text appeared just as it had in the Scrivener (ie w/o italics in some places, etc.). When I switched off the enhanced converter option in Scriv’s Import/Export preferences and tried importing a text file, the rogue text showed up italicized BUT in Helvetica, not in TNR.

At this point, I can import all of my files and then select all to convert the entire text to TNR. I can certainly live with that!

The only issue with the enhanced converter option off is that I lose my file names on import. My test file appears now as the first few words of the file, instead of the file name. Is there a way to revert back to the original file names so that I don’t have to change them all by hand?

Great, glad to hear that worked! Would it be possible to send us a small sample, even just part of one of the .doc files would be fine, that demonstrates this problem? Although we don’t developer the converters ourselves, if there is a bug there we can forward to them with a description on how to reproduce.

Whether you use enhanced converters or not shouldn’t make any difference here. You can toggle that on and off and get an immediate alteration in how the incoming item is named?