Impossible to remove highlight in text

I noted that when I’m in composition mode, a part of my text gets a white highlight. I easily removed it, saved the project and continued writting. But the next time I opened the project, the withe highlight was there again. And this happens every time I re-open the project.

I tried changing the background and text colors, but they are independent of the problem.

I also noticed it happens after the first orange highlight (orange are mine, not a problem)

Captura de pantalla 2016-10-18 a las 13.55.10.png

Yeah we are aware of that one, it looks like Apple changed how highlights are drawn in macOS 10.12. What you see rendered in white here would have been transparent in 10.11, and has been for many years. My guess is that when they tested a tweak to their text engine code, they failed to note that it is possible for text editors to have backgrounds other than white—if your editor was set to white and the text black here you wouldn’t have even noticed it.

To be clear it is a drawing problem, not something to worry about in terms of formatting being messed up. It is obviously also not something that can be easily worked around, other than to temporarily set your composition mode settings to a white background. I know that might very well defeat the purpose, but the only other thing you can do is manually remove them, and as you noted that doesn’t stick, it’s only a temporary solution.

Meanwhile we will put out an update that patches this bug, and have also reported it to Apple in the hopes that they will fix it. So the workaround above is only temporary—sorry about this.

Yes, I imagined something like that since it didn’t give me problem in past days.
Thanks a lot for the help! And I guess my solution will be to turn the background white.
Hope it gets fixed