In-line Spell-check not working on some projects

The in-line spell-check doesn’t seem to be working on one of my projects. When I type in a mispelled word (like “mispelled” right here), it should be underlined in red so I can fix it. No underline in my project. It works here in Safari as I type this, and in Textedit.

I checked another open Scrivener project and it worked there. But not in the main project I want to work on. I even cut-and-pasted a misspelled word from one project to the other and it was only underlined in one.

Weird. Do the spell-check prefs get saved per-project? How would I fix them?

I tried quitting and re-starting Scrivener but no change.

A few users are experiencing the same thing - as far as I can tell, it seems to be an OS X bug whereby OS X is saving the text view’s spell-check settings and overriding Scrivener’s settings, but so far I have been unable to determine the underlying cause, nor why it is affect only some users. Which version of Scrivener are you running? And is it the Mac App Store version or the regular version?

Thanks and all the best,

I’m running the non-macstore version I download myself from your site.
Version 2.3.1 On OS 10.8.2 (MacBookPro 15, unibody 2008)

It’s odd that the spell check underliner is working in some programs (Safari, Textedit,) and in some open Scrivener projects, but not in other open Scrivener projects. I keep assuming it’s a setting I’ve messed up, but I can’t figure out what it is. I hadn’t tried to change the spell-check settings before this.


I wonder if there’s a log that would explain what it’s doing in the one project when it doesn’t register, and the other when it does? I’ll feel really foolish if it’s some simple thing I’m doing.

Thanks for looking at this.

Well, the obvious thing to check is that spell-checking is turned on for the project - spell-check settings are saved per-project. Look to see if “Check spelling while typing” is ticked under the Spelling and Grammar menu in the Edit menu. The only reason I didn’t suggest that to begin with is that some users are finding that spelling remains turned off even when it is ticked there.

If it is ticked and it’s still not working, try making a copy of the project in the Finder and then opening the copy - does spell-checking work there?

Thanks and all the best,

Oh my gosh that did it! Sometimes it’s a relief to feel I’ve missed something so easy.

I kept looking at Scrivener’s global preferences without checking the project’s Edit menu. I had clicked on the “Spelling” toolbar icon too, but didn’t find it there either.

I see it in the Help though under “spelling.” Not sure how that could be more obvious. Not sure how I switched it off, must have hit that keyboard item.

Curious, for a moment while searching the Help, I saw a pull-down menu that looked like a history of my actions, like an “undo” history, which didn’t list when I’d turned spell-check off. Now I don’t see that history. Hmm. Not sure what that was. Might have been handy.

Thank you for your prompt and simple assistance. Onward.

Phew! Glad it was that simple - I’m glad you aren’t one of the handful of users plagued by the spell-check-not-working bug after all, that’s a relief.

Regarding the Help search, you can type the names of menu items in the Help search field to find the menu item, so maybe that was what it was?

All the best,

Yeah, I read about those other folks finding a bug in the App store version and feared the worst.

Thanks for your help!

I might be able to add something to this.

I had a similar problem with spell checking sometimes working and sometimes not. Yesterday spell checking seemed to be working a project I’m working in, but today inline checking seemed to not be working.

I tried turning it off and on, changing the language to “auto” and back to English, etc. I also tried making a copy of the project.

None of these things made the problem go away, but one quirky thing happened that may be useful: On one of a few occasions, a single erroneous word was identified, the first one in the document. On other occasions, and I can repeat this again and again, if I tell scrivener to check spelling now, it finds the first, and ONLY the first misspelled word. If I move the cursor beyond that word, and pick “check spelling now” again, it finds the next misspelled word, but only that one.

Spell checking in line works for other apps.

I’m using Mountain lion, and it is updated, and I’m using the app store version of scrivener.

When I select “System text preferences” from preferences nothing happens that is supposed to happen (I think) but some errors show up in console. I’m going to try to document that here.

So, I start scrivener. Open the document. Turn on Check Spelling while typing. Type misspelled words.

The words are not underlined and console does not show any error.

Then, I move the cursor to the front of the document and select “check spelling now” and it finds only the first one. Nothing on console yet.

Then, I go to preferences, and select “system text preferences”

The control panel for the OS opens in the background not showing any particular panel, just the “all” view. And, the following errors appear on the console:

5/2/13 11:08:58.536 AM appleeventsd[48]: Sandboxed application with pid 654 attempted to lookup App:“System Preferences”/672/0x0:0x92092 sprf1000 sess=100003 but was denied due to sandboxing. (handleMessage()/appleEventsD.cp #2067)

5/2/13 11:08:59.000 AM kernel[0]: Sandbox: sandboxd(673) deny mach-lookup

5/2/13 11:08:59.048 AM sandboxd[673]: ([654]) Scrivener(654) deny appleevent-send

Hope this helps!

If I start a brand new project the spell checker works in it.

Spell check didn’t work for me when I first got Scrivener, then it did for a few months, now it’s back to not working. Frustrating. May be time to move on to another program as a good spell check is key for me.