Including titles in Binder as headings in compiled document

When I compile a document or documents in the Binder I would like to include their titles as headings in the compiled document. I’m not finding any way to do that in the drop-down compile menu. How do I get it to happen?


Eric, the Compile window has, on the left, the Compile Options. Click Formatting and you will see the tick-box options (Title, Meta-Data, Synopsis, Notes, Text). It is probably defaulted to Text only. You can click on Title box to show your titles. As an aside, I use these options a lot and frequently compile with Title and Synopsis only to ensure the flow of my work is consistent etc.

Hope that helps…

Just to clarify a bit, though, when you include titles it’s more like including chapter or section titles; it’s not putting that title into the document header. There’s some in-depth explanation lying around on the forum for why this isn’t possible (to have different headers on different pages throughout the compiled document), but the short and long is that Scrivener can’t create section headers. You can set a different first page (or first x many pages) header by checking the appropriate option and typing in the two different headers you want, but that’s a static page number defined by you, not something the compiler has to calculate based on where text falls in the document. And document variables like <$title> don’t work in the header.

If your finished manuscript requires section headers, this is something you’ll want to do after you export to a dedicated word processor. But if you just need to put in section titles, then that’s entirely doable as thatsawkward explained above.

Thanks. When I click on Formatting, I see that the boxes in the Title and Text columns are checked. I leave them that way. If I click on “Title settings,” I am asked for title “prefix” and “suffix.” I have no idea what a title “prefix” or “suffix” is, so I submit nothing. When I click on “Options,” I see that “Insert subtitles between text elements” is checked. I don’t know what “subtitles” refers to. I suspect it’s not the titles of the documents in the Binder, which is what I want to come out as section headings in the compiled document. I leave this setting as it is.

With these settings, when I compile, document titles are not included as section headings. So I’m still a little baffled.

Thanks. I want to get titles of documents in the Binder to compile/print as chapter and sections titles, not headers.

I don’t need them. I’ve been adding them after compiling, in the word processor. I’d prefer to get them to compile with titles of Binder documents being inserted as section headings. If I understand what thatsawkward suggests its not working for me.

As I say, not critical. I’m not working with a humongous document, and I’ve been adding section titles in the word processor, but its what I’d like to do, if it’s possible.

The Prefix and Suffix option allows you to insert text that can become before or after (or instead of) the document title, such as “Chapter <$t>” which would then add “Chapter One”, “Chapter Two”, etc. in front of each of your titles. (<$t> is a counter variable that just puts in an incremented number as a word with a capital first letter.) The prefix and suffix will get included even if you don’t have the document “title” field checked for compile, which means you can still easily get just “Chapter One”, “Chapter Two” inserted into your compiled document without worrying about what you titled your documents in the binder. (My titles, at least at an early stage, are all just rough descriptions of the scene for my own use, so I wouldn’t want to include them as actual chapter titles, and with this prefix option I can still get “Chapter X” without having to rename the documents.)

Correct. This deals with titles of meta-data, if you’re including them. So it would print “Synopsis,” and then print the synopsis, “Notes,” and then print the notes. If you aren’t compiling anything but the document text and titles, this won’t do anything.

A couple things to check: First, make sure your documents aren’t set in the Content pane to “compile as-is.” With that checked, titles are never printed, regardless of other settings. Second, be sure that the title field in the Formatting pane is checked for the proper document type and level. If the title field is checked for folders only, but the titles you want to include are those of single documents, the proper titles won’t compile.

If that doesn’t work, could you post a screenshot of your settings from the compile “content” and “formatting” panes? That could help figure out what’s the matter. (cmd-shift-4 will let you take a screenshot to your desktop that you can post)

I’m not sure we’re doing the same thing, but it makes me think it might help if I explained what I’m doing. I give documents in the Binder titles that are in effect temporary section headings. They may or may not be the headings I’ll use in the final document. E.g., with the present project – it’s just a book review – I have “introduction,” “credibility,” “causation,” and “instigating dialogue.”

These are not difficult to add after the document has been compiled, but it would be nice to be able to print the resulting document as compiled without having first to do that. One other note about what I’m doing: I can only work so long with the document on screen. Periodically, when I reach a plateau in my editing/revising, I have to print the document out, and work on it as a printed document. Then I go back to the screen, work some more, etc., etc.

Everything in your response is very clear and helpful. I’m not sure about number two above, though. Here’s what the Formatting pane looks like.
In this case I’m printing just one document of about two pages. It’s at the level immediately below the Drafts folder in the Binder. There is no other level below it.

While I’m at it, do you know of a simple utility for taking screen shots that allows you to specify the file type? At this point I’m using Grab, which I take it is the OS X utility. It saves the file as a tiff file. I have have to use Preview to change the file type to one that’s acceptable here.

Documents can be of three types: from top to bottom in the compile Formatting pane (as in your image), you have folder, document group, and single document. In the binder, they look like this:
binder file types.png
Right now, your compile settings print the title (as it appears in the binder) only for folders. If the document you’re printing is a single document or a document group, you need to check the box in the “title” field for each of those. If you always want titles to compile for all your documents, you can just check the “title” box for each type (alt-click on an empty box in the column to check all boxes in the column).

As far as how we’re using the titles, that may be different; I was attempting, poorly, to explain the uses of the prefix/suffix option and a case where that may be desirable. For what you’re doing, though, you don’t want either prefix or suffix and you do want your titles to be added. I realized that, I just didn’t make it clear. :slight_smile: But the directions above are to achieve your ends.

Some people here really like Skitch, but I think the free version only allows you to choose among .png, .jpg, and .skitch (to share with other Skitch users), though the paid-for version has more options. It’s possible to change the format OS X uses when you do the cmd-4 type of screen shot, but it’s not something you’d change per screenshot. (You can type in a line in terminal or you can use a utility like Onyx that brings forward a lot of hidden options and things like that with an easy interface, in which case it’s just checking boxes in a dialogue.) I’m afraid I don’t really have any other experience, but you could ask in the Other Software forum and I’m sure you’d get some good suggestions. Or other people might just respond here. :wink:

Thanks. That did the trick. I didn’t understand what the levels were. As I understand it now, they’re absolute, referring to folder, document group, and document. I was assuming they were relative to the selection at time of compile.

Thanks for the suggestions regarding screen shot options. I’m kind of a minimalist about things, and changing the file type for Grab appeals for that reason. But I can imagine down the road having a little more flexibility of the kind hopefully other utilities would have would be very helpful.

If you check “Compile ignoring levels outside current compile group” in the “Processing Options” pane, then the levels are relative instead of absolute - so you can set it up either way.

All the best,

The document types are what I think was the problem here, not the levels. The types–folder, document group, and single document–don’t change from binder to compile. Levels are relative, but the formatting settings work with the levels for each type, so you’re not setting “all files at level one” to a certain formatting, you’re setting “all folders at level one” as distinct from “all document groups at level one” and so on. Does that make sense?