Incompatible Application can't find answer after searching forum

My issue is this: Scrivener “Incompatible Application” message after running “troubleshoot compatibility”

I searched the archive and found this:

It sounds like the issue I’m having, but I thought, since this thread was from 2010 I should try a new one. I will start by answering the questions the last poster asked and hopefully that will help propel this forward. Thanks!

What version of Windows are you running?
Win7 AMD A6-4400M APU with Radeon HD Graphics 2.70GHz, 64-bit, 786 GB remaining of 1TB

Have you recently made other changes to the computer?

What is happening? What I’ve tried and what’s happening now…
I opened Scrivener for the first time in a couple months. Last time I opened it, I started the tutorial, so the tutorial is what opened. When I tried to click around, the application didn’t respond (note: I did not get a “not responding” message). I thought the file might be corrupt, so I deleted it. No good, it freezes up on the create project screen. I thought it might be Scrivener corrupt. Uninstalled, restart, downloaded new installer, reinstalled. No good, still freezing on create project screen. I can click on “Fiction” and then “Novel”, but I can’t click in the box to name my file or click on browse or click create or cancel. I can click the the red “X” to close.

I think that answers all the questions. I’m still using the trial version. I have 24 non-consecutive uses left. I would really like to try it on a new project so I know whether or not I want to purchase the product.

Thanks for your help!